1 { pkgs ? import <nixpkgs> {}
9 then pkgs.haskellPackages
10 else pkgs.haskell.packages.${ghc};
11 hs = haskellPackages.extend (with pkgs.haskell.lib; hself: hsuper: {
12 #symantic-parser = enableExecutableProfiling (doCheck ( hself.callCabal2nix "symantic-parser" ./. {}));
13 # FIXME: this should not be necessary, but haskellPackages.ormolu is currently broken.
15 text-short = dontCheck hsuper.text-short;
16 hs-speedscope = doJailbreak (unmarkBroken hsuper.hs-speedscope);
17 eventlog2html = doJailbreak (unmarkBroken hsuper.eventlog2html);
18 trie-simple = doJailbreak (unmarkBroken hsuper.trie-simple);
19 symantic-base = buildFromSdist (hself.callCabal2nix "symantic-base" inputs.symantic-base {});
20 symantic-parser = doBenchmark (buildFromSdist (hself.callCabal2nix "symantic-parser" ./. {}));
22 hlint = hsuper.hlint_3_3_1.overrideScope (self: super: {
23 ghc-lib-parser = overrideCabal self.ghc-lib-parser_9_0_1_20210324 {
26 ghc-lib-parser-ex = self.ghc-lib-parser-ex_9_0_0_4;
31 in hs.symantic-parser // {
34 packages = p: [ p.symantic-parser ];
35 # FIXME: remove when Nixpkgs' haskellPackages.ormolu is no longer broken
36 CABAL_TEST_FLAGS = "-fdisable-ormolu-check";
49 #hs.ghc-events-analyze
50 #hs.haskell-language-server