]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/oignon/wireguard.nix
wireguard: use a common config for wg-intra
[julm/julm-nix.git] / hosts / oignon / wireguard.nix
1 { pkgs, lib, config, hostName, private, ... }:
2 {
3 networking.hosts."192.168.42.2" = [
4 "sourcephile.wg"
5 "builds.sourcephile.wg"
6 "dispatch.sourcephile.wg"
7 "git.sourcephile.wg"
8 "hg.sourcephile.wg"
9 "hub.sourcephile.wg"
10 "lists.sourcephile.wg"
11 "man.sourcephile.wg"
12 "meta.sourcephile.wg"
13 "pages.sourcephile.wg"
14 "paste.sourcephile.wg"
15 "todo.sourcephile.wg"
16 ];
17 /*
18 systemd.services =
19 {
20 openssh = {
21 after = ["wireguard-${iface}.service"];
22 serviceConfig.Restart = "on-failure";
23 };
24 };
25 services.openssh.listenAddresses = map (ip: {addr=lib.removeSuffix "/32" ip;}) peer.allowedIPs;
26 */
27 }