]> Git — Sourcephile - julm/julm-nix.git/blob - homes/programs/emacs.nix
xft: move config
[julm/julm-nix.git] / homes / programs / emacs.nix
1 { inputs, pkgs, lib, config, ... }:
2 {
3 options = {
4 programs.doom-emacs = {
5 enable = lib.mkEnableOption "doom-emacs";
6 };
7 };
8 config = lib.mkIf config.programs.doom-emacs.enable {
9 /*
10 imports = [
11 inputs.nix-doom-emacs.hmModule
12 ];
13 programs.doom-emacs = {
14 enable = true;
15 doomPrivateDir =
16 "${config.home.homeDirectory}/.doom.d";
17 };
18 services.emacs = {
19 #enable = true; # Use with emacsclient -c
20 package = config.programs.emacs.package;
21 };
22 */
23 fonts.fontconfig.enable = true;
24 home.packages = with pkgs; [
25 # DOOM Emacs dependencies
26 binutils
27 (ripgrep.override { withPCRE2 = true; })
28 fd
29 gnutls
30 hack-font
31 imagemagick
32 zstd
33 #nodePackages.javascript-typescript-langserver
34 sqlite
35 editorconfig-core-c
36 emacs
37 emacs-all-the-icons-fonts
38 ];
39 home.sessionPath = [ "${config.xdg.configHome}/emacs/bin" ];
40 home.sessionVariables = {
41 DOOMDIR = "${config.xdg.configHome}/doom-config";
42 DOOMLOCALDIR = "${config.xdg.configHome}/doom-local";
43 };
44 xdg.configFile = {
45 #"doom-config/cli.el".text = "";
46 #"doom-config/config.el".source = emacs/config.el;
47 #"doom-config/init.el".source = emacs/init.el;
48 #"doom-config/packages.el".text = "";
49 "emacs" = {
50 source = inputs.doom-emacs;
51 onChange = "${pkgs.writeShellScript "doom-change" ''
52 export DOOMDIR="${config.home.sessionVariables.DOOMDIR}"
53 export DOOMLOCALDIR="${config.home.sessionVariables.DOOMLOCALDIR}"
54 if [ ! -d "$DOOMLOCALDIR" ]; then
55 ${config.xdg.configHome}/emacs/bin/doom -y install
56 else
57 ${config.xdg.configHome}/emacs/bin/doom -y sync -u
58 fi
59 ''}";
60 };
61 };
62 xresources.properties = {
63 #"Emacs.FontBackend" = "xft";
64 };
65 };
66 }