1 { config, pkgs, lib, inputs, machineName, ... }:
3 inherit (config.users) users;
9 oignon/dnscrypt-proxy2.nix
12 documentation.nixos.enable = true;
14 users.mutableUsers = false;
18 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
19 # which is already world readable.
20 hashedPassword = builtins.readFile ../secrets/julm/hashedPassword;
29 # If created, zfs-mount.service would require:
30 # zfs set overlay=yes ${machineName}/home
36 auto-optimise-store = true
41 options = "--delete-older-than 7d";
44 "nixpkgs=/etc/nixpkgs"
45 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
47 trustedUsers = [ users.julm.name ];
49 environment.etc."nixpkgs".source = pkgs.path;
50 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
56 time.timeZone = "Europe/Paris";
57 i18n.defaultLocale = "fr_FR.UTF-8";
58 console.font = "Lat2-Terminus16";
59 console.keyMap = "fr";
62 hostName = machineName;
63 domain = "localdomain";
64 search = [ "sourcephile.fr" ];
71 #backend = "wpa_supplicant";
81 hardware.pulseaudio.enable = true;
83 environment.variables = {
86 SYSTEMD_LESS = "FKMRX";
88 environment.systemPackages = with pkgs; [
146 interactiveShellInit = ''
147 bind '"\e[A":history-search-backward'
148 bind '"\e[B":history-search-forward'
150 # Ignore duplicate commands, ignore commands starting with a space
151 export HISTCONTROL=erasedups:ignorespace
152 export HISTSIZE=42000
153 # Append to the history instead of overwriting (good for multiple connections)
157 mkcd () { mkdir -p "$1"; cd "$1"; }
163 ls = "ls --color=tty";
164 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
167 st="sudo systemctl status";
168 s-u="systemctl --user";
169 j="sudo journalctl -u";
170 jb="sudo journalctl -b";
172 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
174 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
181 enableSSHSupport = true;
193 packages = [ pkgs.gnome3.dconf ];
201 MaxRetentionSec=1month
210 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
222 extraArgs = [ "--verbose" ];
224 "${machineName}/home" = {
233 "${machineName}/var" = {
246 # Allow members of the "adbusers" group to mount Android devices via MTP
247 pkgs.android-udev-rules
253 xkbOptions = "eurosign:e";
254 libinput.enable = true;
257 # Let the session be generated by home-manager
258 { name = "home-manager";
260 ${pkgs.runtimeShell} $HOME/.hm-xsession &
269 pkgs.xfce.thunar-archive-plugin
273 xterm.enable = false;
276 defaultSession = "home-manager";
277 #defaultSession = "none+xmonad";
280 user = users.julm.name;
286 #virtualisation.virtualbox.host.enable = true;
288 # This value determines the NixOS release with which your system is to be
289 # compatible, in order to avoid breaking some software such as database
290 # servers. You should change this only after NixOS release notes say you should.
291 system.stateVersion = "20.09"; # Did you read the comment?