5 enable = mkDefault true;
6 enableCompletion = mkDefault true;
8 afk = "xset s activate dpms force off";
9 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
12 emacs = "emacsclient --create-frame";
13 grep = "grep --color";
14 j = "sudo journalctl -u";
15 jb = "sudo journalctl -b";
16 ju = "sudo journalctl --user -u";
19 ls = "ls --color=tty";
20 md-toc = "grep '^#\\+' --color";
21 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
22 mem-top = "smem --sort rss --autosize";
24 nf = "sudo nft list ruleset | less";
25 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
26 nixos-clean = "sudo nix-collect-garbage -d";
27 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
28 nixos-rollback = "sudo nixos-rebuild switch --rollback";
29 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
31 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
32 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
33 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
35 st = "sudo systemctl status";
40 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
41 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
42 u = "systemctl --user";
43 ut = "systemctl --user status";
44 w1 = "watch --color --differences --interval 1";
45 w5 = "watch --color --differences --interval 5";
46 w10 = "watch --color --differences --interval 10";
47 w = "watch --color --differences";
48 watch = "watch --color --differences";
49 ze = "sudo zpool export";
50 zfs-umount = "zfs-unmount";
51 zi = "sudo zpool import";
53 zlb = "zfs list -t bookmarks";
54 zls = "zfs list -t snap";
58 historyControl = [ "erasedups" "ignorespace" ];
65 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
69 . ${pkgs.complete-alias}/bin/complete_alias
70 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
76 # Disable ctrl-s/ctrl-q flow control
81 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio-only.mkv
86 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
90 find "$@" -depth -type f -print0 | sort -n -z |
91 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
92 test -e "''${0%.*}".opus ||
93 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
98 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
99 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
108 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
111 device=''${1:-/dev/sda}
112 sudo smartctl -A $device |
114 $0 ~ /Power_On_Hours/ {
116 printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25
118 $0 ~ /Total_LBAs_Written/ {
124 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
125 printf "mean writes per hour / %.2f", mb/poh
127 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
128 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
129 $0 ~ /Percentage Used:/ { printf "Percentage_Used / %d\n", int($3) }
132 sed -e "s\$^\$$device @ \$" |
135 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
136 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
137 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
141 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
142 while IFS=: read -r file x size x
148 if test "$pid" = "$lastpid"
149 then swap=$(( swap + size ))
151 if test "$swap" -gt 0
152 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
154 if test "$pid" = self
165 # Recursively mount not-mounted dataset,
166 # loading their keys if needed.
171 for d in $(zfs list -rH -o name "$@"); do
172 mountpoint /mnt/"$d" 2>/dev/null ||
173 sudo zfs mount -l "$d"
176 # Recursively unmount dataset,
177 # unloading their keys.
178 zfs-unmount () { sudo zfs unmount -u "$@"; }
180 # Create bookmarks for all the snapshots of the given datasets.
181 # Bookmarks are only useful on source datasets
182 # But syncoid --create-bookmark only creates
183 # a bookmark for the latest snapshot,
184 # possibly leaving the *_daily or *_monthly snapshots without a bookmark.
185 zfs-fix-bookmarks () {
190 for s in $(zfs list -Hrpt snapshot -o name "$d"); do
191 zfs bookmark "$s" "''${s//@/#}"
196 # Restore the inheritance of encryptionroot,
197 # usually broken by zfs send --raw.
198 # Note that it needs to decrypt the datasets.
199 zfs-fix-encryptionroot () {
202 for d in $(zfs list -rHo name "$1" | tail -n +2); do
204 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
205 zfs change-key -li "$d"
209 # Recursively remove all the snapshots of given datasets
210 zfs-destroy-snapshots () {
213 zfs list -t snapshot -rHo name "$d" |
214 xargs --no-run-if-empty -L1 zfs destroy
221 programs.direnv.enableBashIntegration = true;
222 #programs.broot.enableBashIntegration = true;
223 programs.readline = {
224 enable = mkDefault true;
225 includeSystemConfig = true;
228 "\\e[A" = "history-search-backward";
229 "\\e[B" = "history-search-forward";
230 "\\eOA" = "history-search-backward";
231 "\\eOB" = "history-search-forward";
233 # Ctrl-Left/Ctrl-Right
234 "\\e[1;5C" = "forward-word";
235 "\\e[1;5D" = "backward-word";
236 "\\e[5C" = "forward-word";
237 "\\e[5D" = "backward-word";
238 "\\e\\e[C" = "forward-word";
239 "\\e\\e[D" = "backward-word";
242 "\\e[1~" = "beginning-of-line";
243 "\\e[4~" = "end-of-line";
246 "\\e[3~" = "delete-char";
247 "\\e[2~" = "quoted-insert";
249 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
250 "\\eOF" = "end-of-line";
251 "\\eOH" = "beginning-of-line";
253 # For freebsd console
254 "\\e[F" = "end-of-line";
255 "\\e[H" = "beginning-of-line";
258 "\\e[7~" = "beginning-of-line";
259 "\\e[8~" = "end-of-line";
260 "\\eOc" = "forward-word";
261 "\\eOd" = "backward-word";
266 input-meta = mkDefault true;
267 output-meta = mkDefault true;
268 colored-completion-prefix = mkDefault true;
269 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
270 echo-control-characters = mkDefault true;
271 mark-symlinked-directories = mkDefault true;
272 menu-complete-display-prefix = mkDefault true;
273 show-all-if-ambiguous = mkDefault true;
274 show-all-if-unmodified = mkDefault true;
275 visible-stats = mkDefault false; # Append char to indicate type
276 enable-bracketed-paste = mkDefault true;