5 enable = mkDefault true;
7 afk = "xset s activate dpms force off";
8 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
11 eic = "edit-in-commit";
12 eigg = "edit-in-git-grep";
13 emacs = "emacsclient --create-frame";
16 grep = "grep --color";
17 j = "sudo journalctl -u";
18 jb = "sudo journalctl -b";
19 ju = "sudo journalctl --user -u";
22 ls = "ls --color=tty";
23 md-toc = "grep '^#\\+' --color";
24 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
25 mem-top = "smem --sort rss --autosize";
27 nf = "sudo nft list ruleset | less";
28 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
29 nixos-clean = "sudo nix-collect-garbage -d";
30 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
31 nixos-rollback = "sudo nixos-rebuild switch --rollback";
32 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
34 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
35 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
36 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
38 st = "sudo systemctl status";
43 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
44 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
45 u = "systemctl --user";
46 ut = "systemctl --user status";
47 w1 = "watch --color --differences --interval 1";
48 w5 = "watch --color --differences --interval 5";
49 w10 = "watch --color --differences --interval 10";
50 w = "watch --color --differences";
51 watch = "watch --color --differences";
52 ze = "sudo zpool export";
53 zfs-umount = "zfs-unmount";
54 zi = "sudo zpool import";
59 HISTCONTROL = "erasedups:ignorespace";
61 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
65 . ${pkgs.complete-alias}/bin/complete_alias
66 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
72 # Disable ctrl-s/ctrl-q flow control
77 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio
82 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
87 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
88 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
97 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
100 find "$@" -depth -type f -print0 | sort -n -z |
101 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
102 test -e "''${0%.*}".opus ||
103 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
107 device=''${1:-/dev/sda}
108 sudo smartctl -A $device |
110 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
111 $0 ~ /Total_LBAs_Written/ {
117 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
118 printf "mean writes per hour: / %.2f", mb/poh
120 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
121 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
124 sed -e "s\$^\$$device @ \$" |
127 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
128 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
129 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
133 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
134 while IFS=: read -r file x size x
140 if test "$pid" = "$lastpid"
141 then swap=$(( swap + size ))
143 if test "$swap" -gt 0
144 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
146 if test "$pid" = self
156 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
157 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
159 # Recursively mount not-mounted dataset,
160 # loading their keys if needed.
165 for d in $(zfs list -rH -o name "$@"); do
166 mountpoint /mnt/"$d" 2>/dev/null ||
167 sudo zfs mount -l "$d"
170 # Recursively unmount dataset,
171 # unloading their keys.
172 zfs-unmount () { sudo zfs unmount -u "$@"; }
174 # Restore the inheritance of encryptionroot,
175 # usually broken by zfs send --raw.
176 # Note that it needs to decrypt the datasets.
177 zfs-fix-encryptionroot () {
180 for d in $(zfs list -rHo name "$1" | tail -n +2); do
182 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
183 zfs change-key -li "$d"
187 # Recursively remove all the snapshots of given datasets
188 zfs-destroy-snapshots () {
191 zfs list -t snapshot -rHo name "$d" |
192 xargs --no-run-if-empty -L1 zfs destroy
199 programs.direnv.enableBashIntegration = true;
200 #programs.broot.enableBashIntegration = true;
201 programs.readline = {
202 enable = mkDefault true;
203 includeSystemConfig = true;
206 "\\e[A" = "history-search-backward";
207 "\\e[B" = "history-search-forward";
208 "\\eOA" = "history-search-backward";
209 "\\eOB" = "history-search-forward";
211 # Ctrl-Left/Ctrl-Right
212 "\\e[1;5C" = "forward-word";
213 "\\e[1;5D" = "backward-word";
214 "\\e[5C" = "forward-word";
215 "\\e[5D" = "backward-word";
216 "\\e\\e[C" = "forward-word";
217 "\\e\\e[D" = "backward-word";
220 "\\e[1~" = "beginning-of-line";
221 "\\e[4~" = "end-of-line";
224 "\\e[3~" = "delete-char";
225 "\\e[2~" = "quoted-insert";
227 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
228 "\\eOF" = "end-of-line";
229 "\\eOH" = "beginning-of-line";
231 # For freebsd console
232 "\\e[F" = "end-of-line";
233 "\\e[H" = "beginning-of-line";
236 "\\e[7~" = "beginning-of-line";
237 "\\e[8~" = "end-of-line";
238 "\\eOc" = "forward-word";
239 "\\eOd" = "backward-word";
244 input-meta = mkDefault true;
245 output-meta = mkDefault true;
246 colored-completion-prefix = mkDefault true;
247 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
248 echo-control-characters = mkDefault true;
249 mark-symlinked-directories = mkDefault true;
250 menu-complete-display-prefix = mkDefault true;
251 show-all-if-ambiguous = mkDefault true;
252 show-all-if-unmodified = mkDefault true;
253 visible-stats = mkDefault false; # Append char to indicate type
254 enable-bracketed-paste = mkDefault true;