]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/hardware.nix
aubergine: enable tmpOnTmpfs
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
1 { config, lib, pkgs, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
8 ];
9
10 /*
11 boot.loader.efi = {
12 canTouchEfiVariables = true;
13 efiSysMountPoint = "/boot/efi";
14 };
15 */
16 boot.loader.grub = {
17 enable = true;
18 version = 2;
19 devices = [
20 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
21 "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
22 ];
23 configurationLimit = 9;
24
25 #zfsSupport = true;
26 #efiSupport = true;
27 #enableCryptodisk = true;
28 };
29 boot.tmpOnTmpfs = true;
30
31 fileSystems."/" =
32 { device = "/dev/disk/by-partlabel/${hostName}_sd_root";
33 fsType = "ext4";
34 };
35 fileSystems."/boot/efi" =
36 { device = "/dev/disk/by-partlabel/${hostName}_sd_efi";
37 fsType = "vfat";
38 };
39 /*
40 swapDevices = [
41 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
42 randomEncryption = {
43 enable = true;
44 cipher = "aes-xts-plain64";
45 source = "/dev/urandom";
46 };
47 }
48 ];
49 */
50
51 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
52 # You should try to make this id unique among your hosts.
53 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
54 networking.hostId = "408a404a";
55
56 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
57 boot.extraModulePackages = [
58 #config.boot.kernelPackages.exfat-nofuse
59 ];
60
61 powerManagement.powertop.enable = true;
62 #services.fprintd.enable = true;
63
64 /*
65 fileSystems."/" =
66 { device = "${hostName}/root";
67 fsType = "zfs";
68 };
69 fileSystems."/nix" =
70 { device = "${hostName}/nix";
71 fsType = "zfs";
72 };
73 fileSystems."/var" =
74 { device = "${hostName}/var";
75 fsType = "zfs";
76 };
77 */
78
79 hardware.pulseaudio.enable = lib.mkDefault true;
80 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
81
82 }