]> Git — Sourcephile - julm/julm-nix.git/blob - homes/softwares/bash.nix
bash: add aliases
[julm/julm-nix.git] / homes / softwares / bash.nix
1 { pkgs, lib, config, ... }:
2 {
3 programs.bash = {
4 shellAliases = {
5 cl = "clear";
6 g = "git";
7 grep = "grep --color";
8 j="sudo journalctl -u";
9 jb="sudo journalctl -b";
10 l = "ls -alh";
11 ll = "ls -al";
12 ls = "ls --color=tty";
13 md-toc = "grep '^#\\+' --color";
14 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
15 mem-top = "smem --sort rss --autosize";
16 mpl = "mplayer";
17 nixos-clean="sudo nix-collect-garbage -d";
18 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
19 nixos-rollback="sudo nixos-rebuild switch --rollback";
20 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
21 s="sudo systemctl";
22 st="sudo systemctl status";
23 u="systemctl --user";
24 ut="systemctl --user status";
25 watch = "watch --color";
26 };
27 initExtra = ''
28 shopt -s globstar
29 # Disable ctrl-s/ctrl-q flow control
30 stty -ixon
31
32 smartctl-tbw () {
33 device=''${1:-/dev/sda}
34 sudo smartctl -A $device |
35 { awk '
36 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
37 $0 ~ /Total_LBAs_Written/ {
38 lbas = $10;
39 bytes = $10 * 512;
40 mb = bytes / 1024^2;
41 gb = bytes / 1024^3;
42 tb = bytes / 1024^4;
43 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
44 printf "mean writes per hour: / %.2f", mb/poh
45 }
46 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
47 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
48 '; echo; } |
49 sed -e 's:/:@:' |
50 sed -e "s\$^\$$device @ \$" |
51 column -ts@
52 }
53 swaplist () {
54 lastpid=
55 swap=0
56 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
57 while IFS=: read -r file x size x
58 do
59 pid=''${file#/proc/}
60 pid=''${pid%/smaps}
61 size=''${size% kB}
62 size=''${size##* }
63 if test "$pid" = "$lastpid"
64 then swap=$(( swap + size ))
65 else
66 if test "$swap" -gt 0
67 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
68 fi
69 if test "$pid" = self
70 then break
71 else
72 lastpid=$pid
73 swap=$size
74 fi
75 fi
76 done |
77 sort -nk1,1
78 }
79 vim-git () { $EDITOR $(git diff-tree --no-commit-id --name-only --recursive "$@"); }
80 vim-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
81 zfs-mount () { for d in $(zfs list -rH -o name "$@"); do sudo zfs mount -l "$d"; done; }
82 zfs-unmount () { sudo zfs unmount -u "$@"; }
83 '';
84 profileExtra = ''
85 '';
86 };
87 programs.direnv.enableBashIntegration = true;
88 programs.broot.enableBashIntegration = true;
89 home.sessionVariables = {
90 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
91 };
92 programs.readline = {
93 enable = lib.mkDefault config.programs.bash.enable;
94 includeSystemConfig = true;
95 bindings = {
96 "\\eOF" = "end-of-line";
97 "\\eOH" = "beginning-of-line";
98 "\\e[1;5C" = "forward-word";
99 "\\e[1;5D" = "backward-word";
100 "\\e[1~" = "beginning-of-line";
101 "\\e[4~" = "end-of-line";
102 "\\e[5C" = "forward-word";
103 "\\e[5D" = "backward-word";
104 "\\e[7~" = "beginning-of-line";
105 "\\e[8~" = "end-of-line";
106 "\\e[A" = "history-search-backward";
107 "\\e[B" = "history-search-forward";
108 "\\e[F" = "end-of-line";
109 "\\e[H" = "beginning-of-line";
110 "\\e\\e[C" = "forward-word";
111 "\\e\\e[D" = "backward-word";
112 };
113 variables = {
114 colored-completion-prefix = lib.mkDefault true;
115 colored-stats = lib.mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
116 echo-control-characters = lib.mkDefault true;
117 mark-symlinked-directories = lib.mkDefault true;
118 menu-complete-display-prefix = lib.mkDefault true;
119 show-all-if-ambiguous = lib.mkDefault true;
120 show-all-if-unmodified = lib.mkDefault true;
121 visible-stats = lib.mkDefault false; # Append char to indicate type
122 };
123 };
124 }