1 { lib, hostName, ... }:
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
10 # Setting the machine-id avoids to reencrypt all credentials
11 # when reinstalling NixOS on a new drive.
12 # Manually generated with : uuidgen | tr -d -
13 environment.etc.machine-id.source = ./machine-id.clear;
15 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
16 # You should try to make this id unique among your hosts.
17 # Manually generated with : uuidgen | head -c8
18 networking.hostId = "408a404a";
22 canTouchEfiVariables = true;
23 efiSysMountPoint = "/boot/efi";
29 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
30 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
31 "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
33 configurationLimit = 9;
37 #enableCryptodisk = true;
39 boot.tmp.useTmpfs = true;
41 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
42 boot.extraModulePackages = [
43 #config.boot.kernelPackages.exfat-nofuse
46 powerManagement.powertop.enable = true;
47 #services.fprintd.enable = true;
51 device = "${hostName}/root";
56 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
59 fileSystems."/boot/efi" =
61 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
66 device = "${hostName}/nix";
71 device = "${hostName}/var";
76 device = "${hostName}/home";
82 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
85 cipher = "aes-xts-plain64";
86 source = "/dev/urandom";
91 hardware.pulseaudio.enable = lib.mkDefault true;
92 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;