]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/mpv.nix
audio: install easyeffects
[julm/julm-nix.git] / home-manager / profiles / mpv.nix
1 { pkgs, ... }:
2 {
3 home.packages = [
4 pkgs.mpv
5 ];
6 xdg.configFile."mpv/input.conf".text = ''
7 # Volume normalization
8 # See https://github.com/mpv-player/mpv/issues/3979
9 Alt+a cycle-values af "dynaudnorm=framelen=500:gausssize=31:coupling=1:peak=0.58" "loudnorm" ""
10 Alt+f cycle video-unscaled
11
12 # Show all chapters (like a right-clic on |<< or >>|)
13 c show_text ''${chapter-list}
14 '';
15 xdg.configFile."mpv/mpv.conf".text = ''
16 hwdec=auto-safe
17 profile=gpu-hq
18 vo=gpu
19 ytdl-format=18/mp4-480p/hls-480p/http-360p/mp4
20 '';
21 }