1 { pkgs, hostName, ... }:
4 ../../nixos/profiles/hardware/E5500.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
9 # Setting the machine-id avoids to reencrypt all credentials
10 # when reinstalling NixOS on a new drive.
11 # Manually generated with : uuidgen | tr -d -
12 environment.etc.machine-id.source = ./machine-id.clear;
14 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
15 # You should try to make this id unique among your hosts.
16 # Manually generated with : uuidgen | head -c8
17 networking.hostId = "e53001b7";
22 memtest86.enable = true;
24 { path = "/boot1"; devices = [ "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD5" ]; }
26 # Roughly 25MiB (initrd) + 9MiB (kernel) per configuration
27 configurationLimit = 6;
31 #enableCryptodisk = true;
34 boot.zfs.requestEncryptionCredentials = [ "${hostName}/root" ];
36 hardware.enableRedistributableFirmware = true;
38 fileSystems."/boot1" =
40 device = "/dev/disk/by-partlabel/${hostName}_ssd1_boot";
42 options = [ "rw" "noexec" "nodev" "nofail" "X-mount.mkdir" "iocharset=iso8859-1" ];
46 device = "/dev/disk/by-partlabel/${hostName}_ssd1_swap";
49 cipher = "aes-xts-plain64";
50 source = "/dev/urandom";
55 boot.supportedFilesystems = [ "ntfs" "vfat" ];
59 device = "${hostName}/root";
61 options = [ "zfsutil" ];
65 device = "${hostName}/root/nix";
67 options = [ "X-mount.mkdir" "zfsutil" ];
71 device = "${hostName}/root/var";
73 options = [ "X-mount.mkdir" "zfsutil" ];
76 services.pipewire.jack.enable = true;