1 { pkgs, lib, config, inputs, hostName, ... }:
3 domain = "sourcephile.fr";
4 iface = config.services.nebula.networks.${domain}.tun.device;
8 ../../share/nebula/sourcephile.fr.nix
10 services.nebula.networks.${domain} = {
14 { port = "any"; proto = "any"; groups = [ "sourcephile" "intra" ]; }
17 { port = "any"; proto = "any"; host = "any"; }
27 networking.nftables.ruleset = ''
29 chain input-${iface} {
31 chain output-${iface} {
32 tcp dport 9091 counter accept comment "Transmission RPC"