]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
aubergine: nftables: fix DHCP renewal
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 enableCompletion = mkDefault true;
7 shellAliases = {
8 afk = "xset s activate dpms force off";
9 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
10 c = "bat";
11 cl = "clear";
12 d = "sudo resolvectl";
13 dust = "dust --bars-on-right --full-paths";
14 emacs = "emacsclient --create-frame";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 jf = "sudo journalctl -f -u";
19 jf200 = "sudo journalctl -f -n 200 -u";
20 jftoday = "sudo journalctl -f --since today -u";
21 ju = "journalctl --user -u";
22 l = "ls -alh";
23 ll = "ls -al";
24 ls = "ls --color=tty";
25 lst = "ls --sort=time --reverse -1";
26 md-toc = "grep '^#\\+' --color";
27 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
28 mem-top = "smem --sort rss --autosize";
29 mpl = "mplayer";
30 n = "sudo networkctl";
31 nf = "sudo nft list ruleset | less";
32 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
33 nixos-clean = "sudo nix-collect-garbage -d";
34 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
35 nixos-rollback = "sudo nixos-rebuild switch --rollback";
36 nt = "sudo networkctl status";
37 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
38 r = "reset";
39 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
40 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
41 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
42 s = "sudo systemctl";
43 sr = "sudo systemctl restart";
44 ssh-unknown = "ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null";
45 st = "sudo systemctl status";
46 smt-on = "echo on | sudo tee /sys/devices/system/cpu/smt/control";
47 smt-off = "echo off | sudo tee /sys/devices/system/cpu/smt/control";
48 t = "tmux";
49 t0 = "tmux new -t 0";
50 t1 = "tmux new -t 1";
51 t2 = "tmux new -t 2";
52 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
53 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
54 u = "systemctl --user";
55 ud = "resolvectl";
56 ur = "systemctl --user restart";
57 ut = "systemctl --user status";
58 w = "watch --color --differences";
59 w1 = "watch --color --differences --interval 1";
60 w10 = "watch --color --differences --interval 10";
61 w5 = "watch --color --differences --interval 5";
62 watch = "watch --color --differences";
63 z = "zfs";
64 ze = "sudo zpool export";
65 zfs-umount = "zfs-unmount";
66 zi = "sudo zpool import";
67 zl = "zfs list";
68 zlb = "zfs list -t bookmarks";
69 zls = "zfs list -t snap";
70 zm = "zfs-mount";
71 zp = "sudo zpool";
72 zs = "zpool status";
73 zs5 = "w5 zpool status";
74 zu = "zfs-unmount";
75 };
76 historyControl = [ "erasedups" "ignorespace" ];
77 historyIgnore = [
78 "torify"
79 "mpv"
80 ];
81 historySize = 42000;
82 sessionVariables = {
83 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
84 # More throughput than chacha20-poly1305@openssh.com
85 # on hardware with AES acceleration.
86 RSYNC_RSH = "ssh -c aes128-gcm@openssh.com,chacha20-poly1305@openssh.com";
87 };
88 initExtra = ''
89 # Alias completion
90 . ${pkgs.complete-alias}/bin/complete_alias
91 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
92
93 shopt -s globstar
94 shopt -s histappend
95 shopt -s histreedit
96 shopt -s histverify
97 # Disable ctrl-s/ctrl-q flow control
98 stty -ixon
99
100 ffmpeg-audio () {
101 for i in "$@"; do
102 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio-only.mkv
103 done
104 }
105 ffmpeg-opus () {
106 for i in "$@"; do
107 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
108 done
109 }
110 opusenc-voice () {
111 find "$@" -depth -type f -print0 | sort -n -z |
112 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
113 test -e "''${0%.*}".opus ||
114 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
115 ' {} \;
116 }
117 ibm-fan () {
118 if [ $# -gt 0 ]
119 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
120 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
121 fi
122 acpi -t
123 }
124 mkcd () {
125 mkdir -p "$1" &&
126 cd "$1"
127 }
128 mkpass () {
129 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
130 }
131 smartctl-tbw () {
132 device=''${1:-/dev/sda}
133 sudo smartctl -A $device |
134 { awk '
135 $0 ~ /Power_On_Hours/ {
136 poh=$10;
137 printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25
138 }
139 $0 ~ /Total_LBAs_Written/ {
140 lbas = $10;
141 bytes = $10 * 512;
142 mb = bytes / 1024^2;
143 gb = bytes / 1024^3;
144 tb = bytes / 1024^4;
145 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
146 printf "mean writes per hour / %.2f", mb/poh
147 }
148 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
149 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
150 $0 ~ /Percentage Used:/ { printf "Percentage_Used / %d\n", int($3) }
151 '; echo; } |
152 sed -e 's:/:@:' |
153 sed -e "s\$^\$$device @ \$" |
154 column -ts@
155 }
156 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
157 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
158 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
159 swaplist () {
160 lastpid=
161 swap=0
162 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
163 while IFS=: read -r file x size x
164 do
165 pid=''${file#/proc/}
166 pid=''${pid%/smaps}
167 size=''${size% kB}
168 size=''${size##* }
169 if test "$pid" = "$lastpid"
170 then swap=$(( swap + size ))
171 else
172 if test "$swap" -gt 0
173 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
174 fi
175 if test "$pid" = self
176 then break
177 else
178 lastpid=$pid
179 swap=$size
180 fi
181 fi
182 done |
183 sort -nk1,1
184 }
185
186 # Recursively mount not-mounted dataset,
187 # loading their keys if needed.
188 zfs-mount () {
189 (
190 set -e
191 for d in $(zfs list -rH -o name "$@"); do
192 mountpoint /mnt/"$d" 2>/dev/null ||
193 sudo zfs mount -l "$d"
194 done
195 )
196 }
197 # Recursively unmount dataset,
198 # unloading their keys.
199 zfs-unmount () { sudo zfs unmount -u "$@"; }
200
201 # Create bookmarks for all the snapshots of the given datasets.
202 # Bookmarks are only useful on source datasets
203 # But syncoid --create-bookmark only creates
204 # a bookmark for the latest snapshot,
205 # possibly leaving the *_daily or *_monthly snapshots without a bookmark.
206 zfs-fix-bookmarks () {
207 local d
208 local -
209 set -x
210 for d in "$@"; do
211 for s in $(zfs list -Hrpt snapshot -o name "$d"); do
212 sudo zfs bookmark "$s" "''${s//@/#}"
213 done
214 done
215 }
216
217 # Restore the inheritance of encryptionroot,
218 # usually broken by zfs send --raw.
219 # Note that it needs to decrypt the datasets.
220 zfs-fix-encryptionroot () {
221 local d
222 zfs load-key "$1"
223 for d in $(zfs list -rHo name "$1" | tail -n +2); do
224 echo >&2 "$d"
225 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
226 sudo zfs change-key -li "$d"
227 done
228 }
229
230 # Recursively remove all the snapshots of given datasets
231 zfs-destroy-snapshots () {
232 local d
233 for d in "$@"; do
234 zfs list -t snapshot -rHo name "$d" |
235 sudo xargs --no-run-if-empty -L1 zfs destroy
236 done
237 }
238 '';
239 profileExtra = ''
240 '';
241 };
242 #programs.broot.enableBashIntegration = true;
243 programs.readline = {
244 enable = mkDefault true;
245 includeSystemConfig = true;
246 bindings = {
247 # Up/Down
248 "\\e[A" = "history-search-backward";
249 "\\e[B" = "history-search-forward";
250 "\\eOA" = "history-search-backward";
251 "\\eOB" = "history-search-forward";
252
253 # Ctrl-Left/Ctrl-Right
254 "\\e[1;5C" = "forward-word";
255 "\\e[1;5D" = "backward-word";
256 "\\e[5C" = "forward-word";
257 "\\e[5D" = "backward-word";
258 "\\e\\e[C" = "forward-word";
259 "\\e\\e[D" = "backward-word";
260
261 # Home/End
262 "\\e[1~" = "beginning-of-line";
263 "\\e[4~" = "end-of-line";
264
265 # Delete/Insert
266 "\\e[3~" = "delete-char";
267 "\\e[2~" = "quoted-insert";
268
269 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
270 "\\eOF" = "end-of-line";
271 "\\eOH" = "beginning-of-line";
272
273 # For freebsd console
274 "\\e[F" = "end-of-line";
275 "\\e[H" = "beginning-of-line";
276
277 # $if term=rxvt
278 "\\e[7~" = "beginning-of-line";
279 "\\e[8~" = "end-of-line";
280 "\\eOc" = "forward-word";
281 "\\eOd" = "backward-word";
282 # $endif
283 };
284 variables = {
285 # Be 8 bit clean.
286 input-meta = mkDefault true;
287 output-meta = mkDefault true;
288 colored-completion-prefix = mkDefault true;
289 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
290 echo-control-characters = mkDefault true;
291 mark-symlinked-directories = mkDefault true;
292 menu-complete-display-prefix = mkDefault true;
293 show-all-if-ambiguous = mkDefault true;
294 show-all-if-unmodified = mkDefault true;
295 visible-stats = mkDefault false; # Append char to indicate type
296 enable-bracketed-paste = mkDefault true;
297 };
298 };
299 }