1 { config, pkgs, lib, inputs, ... }:
4 ../nixos/profiles/router.nix
5 #../nixos/profiles/debug.nix
6 ../nixos/profiles/lang-fr.nix
7 #../nixos/profiles/tor.nix
8 ../nixos/profiles/networking/remote.nix
9 ../nixos/profiles/home.nix
10 aubergine/hardware.nix
12 aubergine/networking.nix
13 aubergine/printing.nix
19 # Lower kernel's security for better performances
20 security.kernel.mitigations = "off";
22 home-manager.users.julm = {
23 imports = [ ../homes/julm.nix ];
29 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
30 # which is already world readable.
31 # printf %s $(mkpasswd -m yescrypt)
32 hashedPassword = lib.readFile aubergine/users/julm/login/hashedPassword.clear;
44 openssh.authorizedKeys.keys = map lib.readFile [
45 ../users/root/ssh/losurdo.pub
46 ../users/julm/ssh/losurdo.pub
47 ../users/julm/ssh/oignon.pub
48 ../users/julm/ssh/pumpkin.pub
49 ../users/julm/ssh/redmi.pub
54 openssh.authorizedKeys.keys =
55 config.users.users.julm.openssh.authorizedKeys.keys;
64 openssh.authorizedKeys.keys = map lib.readFile [
65 ../users/sevy/ssh/patate.pub
70 #systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted =
71 # "secret-key-files:" + aubergine/nix/secret-key-files;
74 #secret-key-files = /run/credentials/nix-daemon.service/secret-key-files.pem
78 #"http://nix-localcache.losurdo.wg"
79 #"ssh://nix-ssh@losurdo.wg?priority=30"
80 #"ssh://nix-ssh@oignon.wg?priority=30"
82 trusted-public-keys = map lib.readFile [
83 #../users/root/nix/oignon.pub
84 #../users/root/nix/pumpkin.pub
87 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
89 #environment.etc."nixpkgs".source = pkgs.path;
90 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
92 nix.settings.allowed-users = [ config.users.users."nix-ssh".name ];
95 keys = map lib.readFile [
96 ../users/julm/ssh/losurdo.pub
97 ../users/sevy/ssh/patate.pub
98 ../users/julm/ssh/oignon.pub
99 ../users/julm/ssh/pumpkin.pub
103 environment.systemPackages = [
106 boot.extraModulePackages = [
107 #config.boot.kernelPackages.v4l2loopback
110 # This value determines the NixOS release with which your system is to be
111 # compatible, in order to avoid breaking some software such as database
112 # servers. You should change this only after NixOS release notes say you should.
113 system.stateVersion = "22.11"; # Did you read the comment?