]> Git — Sourcephile - julm/julm-nix.git/blob - homes/programs/htop.nix
htop: tweak settings
[julm/julm-nix.git] / homes / programs / htop.nix
1 { lib, ...}:
2 {
3 # This must appear before "column_meters_*" options
4 xdg.configFile."htop/htoprc".text = lib.mkBefore ''
5 header_layout=two_50_50
6 '';
7 programs.htop = {
8 settings = {
9 account_guest_in_cpu_meter = false;
10 all_branches_collapsed = false;
11 color_scheme = false;
12 column_meter_modes_0 = "3 1 1 1";
13 column_meter_modes_1 = "2 2 2 3 3 1 1 1";
14 column_meters_0 = "AllCPUs Memory Swap Zram";
15 column_meters_1 = "Systemd LoadAverage Uptime DiskIO NetworkIO ZFSARC ZFSCARC PressureStallIOFull";
16 cpu_count_from_one = false;
17 degree_fahrenheit = false;
18 delay = 15;
19 detailed_cpu_time = true;
20 enable_mouse = true;
21 find_comm_in_cmdline = true;
22 header_margin = true;
23 hide_function_bar = false;
24 hide_kernel_threads = true;
25 hide_threads = true;
26 hide_userland_threads = false;
27 highlight_base_name = true;
28 highlight_changes = false;
29 highlight_changes_delay_secs = 5;
30 highlight_deleted_exe = true;
31 highlight_megabytes = true;
32 highlight_threads = true;
33 shadow_other_users = false;
34 show_cpu_frequency = true;
35 show_cpu_temperature = false;
36 show_cpu_usage = true;
37 show_merged_command = false;
38 show_program_path = false;
39 show_thread_names = false;
40 sort_direction = 0;
41 sort_key = 46; # PERCENT_CPU
42 strip_exe_from_cmdline = true;
43 tree_sort_direction = 0;
44 tree_sort_key = 46; # PERCENT_CPU
45 tree_view = true;
46 tree_view_always_by_pid = false;
47 update_process_names = false;
48 };
49 };
50 }