7 # error: phantomjs 1.9.8 has been dropped due to lack of maintenance and security issues
11 programs.bash.shellAliases = {
13 yt-audio = "yt-dlp -f 'worstaudio[acodec=opus]/worstaudio'";
15 xdg.configFile."yt-dlp/config".text = ''
16 #--download-archive .downloaded
17 --external-downloader aria2c
21 --format ${lib.concatStringsSep "/" [
22 "bestvideo[height<=480][vcodec=av1]+bestaudio"
23 #"bestvideo[height<=480][vcodec=vp9]+bestaudio"
24 "bestvideo[height<=480][ext=mp4]+bestaudio"
25 "bestvideo[height<=480]+bestaudio"
27 "best[height<=480][ext=av1]"
28 #"best[height<=480][ext=vp9]"
29 "best[height<=480][ext=mp4]"
34 --output "%(release_date>%Y-%m-%d,upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
35 --match-filter !is_live
37 --sub-format ass/srt/best
38 --sub-langs "en.*,fr,-live_chat,-rechat"
39 --user-agent "Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/110.0"