]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/xfce.nix
nix: update inputs
[julm/julm-nix.git] / home-manager / profiles / xfce.nix
1 { pkgs, lib, config, ... }:
2 {
3 home.file.".profile".text = ''
4 # Tell XFCE to not start ssh-agent
5 if command -v xfconf-query >/dev/null && test ''${DISPLAY:+set}; then
6 xfconf-query -c xfce4-session -p /startup/ssh-agent/enabled -n -t bool -s false
7 fi
8 '';
9 home.packages = [
10 pkgs.mate.caja-with-extensions # Thunar does not map user_id over sftp://
11 pkgs.elementary-xfce-icon-theme
12 pkgs.gnome3.adwaita-icon-theme
13 pkgs.gnome3.file-roller
14 pkgs.gnome3.gnome-calculator
15 pkgs.gnome3.gnome-keyring
16 pkgs.gnome3.seahorse
17 pkgs.hicolor-icon-theme
18 pkgs.xfce.thunar-volman
19 ];
20 }