1 { config, pkgs, lib, inputs, hostName, ... }:
4 ../nixos/profiles/builder.nix
5 ../nixos/profiles/debug.nix
6 ../nixos/profiles/graphical.nix
7 ../nixos/profiles/lang-fr.nix
8 ../nixos/profiles/printing.nix
9 ../nixos/profiles/security.nix
10 ../nixos/profiles/system.nix
11 ../nixos/profiles/tor.nix
12 ../nixos/profiles/irssi.nix
18 # Lower kernel's security for better performances
19 boot.kernelParams = [ "mitigations=off" ];
21 home-manager.users.julm = {
22 imports = [ ../homes/julm.nix ];
24 systemd.services.home-manager-julm.postStart = ''
25 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
28 openssh.authorizedKeys.keys = map lib.readFile [
29 # For nix -L run .#oignon.switch
30 ../users/julm/ssh/oignon.pub
36 # Put the hashedPassword in /nix/store,
37 # though /etc/shadow is not world readable...
38 # printf %s $(mkpasswd -m md5crypt)
39 hashedPassword = lib.readFile oignon/users/julm/login/hashedPassword.clear;
50 config.services.davfs2.davGroup
53 # If created, zfs-mount.service would require:
54 # zfs set overlay=yes ${hostName}/home
56 openssh.authorizedKeys.keys = map lib.readFile [
57 ../users/julm/ssh/losurdo.pub
61 systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted =
62 [ ("${hostName}.key:" + inputs.self + "/hosts/${hostName}/nix/secret-key-files.priv.pem.cred") ];
65 secret-key-files = /run/credentials/nix-daemon.service/${hostName}.key
68 trusted-users = [ config.users.users."julm".name ];
70 #"http://nix-localcache.losurdo.wg"
71 "ssh://nix-ssh@losurdo.wg?priority=30"
73 trusted-public-keys = map lib.readFile [
74 ../hosts/losurdo/nix/key.pub
77 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
79 #environment.etc."nixpkgs".source = pkgs.path;
80 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
82 nix.settings.allowed-users = [ config.users.users."nix-ssh".name ];
85 keys = map lib.readFile [
86 ../users/julm/ssh/losurdo.pub
87 ../users/julm/ssh/oignon.pub
88 ../users/sevy/ssh/patate.pub
92 environment.systemPackages = [
93 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
96 boot.extraModulePackages = [
97 #config.boot.kernelPackages.v4l2loopback
100 programs.fuse.userAllowOther = true;
102 services.davfs2.enable = true;
105 # Use the user's gpg-agent session to query
106 # for the password of the SSH key when auto-mounting.
109 pkgs.writeScript "sshAsUser-${user}" ''
110 exec ${pkgs.sudo}/bin/sudo -i -u ${user} \
111 ${pkgs.openssh}/bin/ssh "$@"
123 "ssh_command=${sshAsUser "julm"}" # "reconnect"
126 "x-systemd.automount"
127 #"Compression=yes" # YMMV
128 # Disconnect approximately 2*15=30 seconds after a network failure
129 "ServerAliveCountMax=1"
130 "ServerAliveInterval=15"
135 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@aubergine.wg:/";
140 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@losurdo.wg:/";
145 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@mermet.wg:/";
149 "/mnt/ilico/severine" = {
150 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
154 conf = pkgs.writeText "davfs2.conf" ''
155 backup_dir /home/julm/.local/share/davfs2/ilico/severine
156 secrets /home/julm/.davfs2/secrets
168 "x-systemd.automount"
169 "x-systemd.device-timeout=1m"
170 "x-systemd.idle-timeout=1m"
171 "x-systemd.mount-timeout=10s"
176 networking.firewall.extraCommands = ''
177 ip46tables -A nixos-fw -i wg-intra -p tcp -m tcp --dport 8000 -j ACCEPT
182 defaultMode = "online";
185 localDiscovery = false;
187 Datastore.StorageMax = "10GB";
188 Discovery.MDNS.Enabled = false;
191 #Swarm.AddrFilters = null;
193 startWhenNeeded = true;
196 services.udev.packages = [
197 # Allow the console user access the Yubikey USB device node,
198 # needed for challenge/response to work correctly.
199 pkgs.yubikey-personalization
205 # Let the session be generated by home-manager
207 name = "home-manager";
209 ${pkgs.runtimeShell} $HOME/.hm-xsession &
216 defaultSession = "home-manager";
217 #defaultSession = "none+xmonad";
218 #defaultSession = "mate";
219 #defaultSession = "cinnamon";
221 user = config.users.users.julm.name;
226 # This value determines the NixOS release with which your system is to be
227 # compatible, in order to avoid breaking some software such as database
228 # servers. You should change this only after NixOS release notes say you should.
229 system.stateVersion = "20.09"; # Did you read the comment?