1 { config, pkgs, lib, inputs, private, hostName, ... }:
4 ../nixos/profiles/builder.nix
5 ../nixos/profiles/debug.nix
6 ../nixos/profiles/dnscrypt-proxy2.nix
7 ../nixos/profiles/graphical.nix
8 ../nixos/profiles/lang-fr.nix
9 ../nixos/profiles/networking.nix
10 ../nixos/profiles/printing.nix
11 ../nixos/profiles/security.nix
12 ../nixos/profiles/system.nix
13 ../nixos/profiles/tor.nix
14 ../nixos/profiles/irssi.nix
15 ../nixos/profiles/wireguard/wg-intra.nix
21 home-manager.users.julm = {
22 imports = [ ../homes/julm.nix ];
23 host.hardware = [ "ThinkPad" "X201" ];
25 systemd.services.home-manager-julm.postStart = ''
26 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
31 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
32 # which is already world readable.
33 hashedPassword = lib.readFile ../private/world/julm/hashedPassword;
44 config.services.davfs2.davGroup
47 # If created, zfs-mount.service would require:
48 # zfs set overlay=yes ${hostName}/home
50 openssh.authorizedKeys.keys = map lib.readFile [
51 ../private/shared/ssh/julm/losurdo.pub
57 #secret-key-files = /run/credentials/nix-daemon.service/secret-key-files.pem
58 secret-key-files = ${private}/${hostName}/nix/binary-cache/priv.pem
61 trusted-users = [ config.users.users."julm".name ];
63 #"http://nix-localcache.losurdo.wg"
64 "ssh://nix-ssh@losurdo.wg?priority=30"
66 trusted-public-keys = map lib.readFile [
67 ../private/shared/nix/losurdo.pub
70 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
72 #environment.etc."nixpkgs".source = pkgs.path;
73 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
75 nix.settings.allowed-users = [ config.users.users."nix-ssh".name ];
78 keys = map lib.readFile [
79 ../private/shared/ssh/julm/losurdo.pub
80 ../private/shared/ssh/sevy/patate.pub
81 ../private/shared/ssh/julm/oignon.pub
85 environment.systemPackages = [
86 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
89 boot.extraModulePackages = [
90 #config.boot.kernelPackages.v4l2loopback
93 programs.fuse.userAllowOther = true;
95 services.davfs2.enable = true;
98 # Use the user's gpg-agent session to query
99 # for the password of the SSH key when auto-mounting.
102 pkgs.writeScript "sshAsUser-${user}" ''
103 exec ${pkgs.sudo}/bin/sudo -i -u ${user} \
104 ${pkgs.openssh}/bin/ssh "$@"
108 "noatime" "noexec" "nosuid"
109 "user" "uid=julm" "gid=users" "allow_other"
110 "_netdev" "ssh_command=${sshAsUser "julm"}" # "reconnect"
111 "noauto" "x-gvfs-hide" "x-systemd.automount"
112 #"Compression=yes" # YMMV
113 # Disconnect approximately 2*15=30 seconds after a network failure
114 "ServerAliveCountMax=1"
115 "ServerAliveInterval=15"
119 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@losurdo.wg:/";
124 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@mermet.wg:/";
128 "/mnt/ilico/severine" = {
129 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
132 let conf = pkgs.writeText "davfs2.conf" ''
133 backup_dir /home/julm/.local/share/davfs2/ilico/severine
134 secrets /home/julm/.davfs2/secrets
136 [ "conf=${conf}" "user" "noexec" "nosuid"
137 "noauto" "nofail" "_netdev" "reconnect"
138 "x-systemd.automount"
139 "x-systemd.device-timeout=1m"
140 "x-systemd.idle-timeout=1m"
141 "x-systemd.mount-timeout=10s"
146 networking.firewall.extraCommands = ''
147 ip46tables -A nixos-fw -i wg-intra -p tcp -m tcp --dport 8000 -j ACCEPT
152 defaultMode = "online";
155 localDiscovery = false;
157 Datastore.StorageMax = "10GB";
158 Discovery.MDNS.Enabled = false;
161 #Swarm.AddrFilters = null;
163 startWhenNeeded = true;
166 services.udev.packages = [
167 # Allow the console user access the Yubikey USB device node,
168 # needed for challenge/response to work correctly.
169 pkgs.yubikey-personalization
175 # Let the session be generated by home-manager
176 { name = "home-manager";
178 ${pkgs.runtimeShell} $HOME/.hm-xsession &
185 defaultSession = "home-manager";
186 #defaultSession = "none+xmonad";
187 #defaultSession = "mate";
188 #defaultSession = "cinnamon";
190 user = config.users.users.julm.name;
195 # This value determines the NixOS release with which your system is to be
196 # compatible, in order to avoid breaking some software such as database
197 # servers. You should change this only after NixOS release notes say you should.
198 system.stateVersion = "20.09"; # Did you read the comment?