1 { config, lib, pkgs, hostName, ... }:
4 ../../nixos/profiles/acpid.nix
5 ../../nixos/profiles/hardware/thinkpad.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
12 canTouchEfiVariables = true;
13 efiSysMountPoint = "/boot/efi";
19 device = "/dev/disk/by-id/ata-Samsung_SSD_850_PRO_128GB_S1SMNSAFC36436X";
20 configurationLimit = 3;
24 #enableCryptodisk = true;
27 services.udev.packages = [
32 # https://www.thinkwiki.org/wiki/Qualcomm_Gobi_2000
33 (pkgs.runCommandNoCC "firmware-gobi" {} ''
34 mkdir -p $out/lib/firmware
35 # Fails due to forced compression https://github.com/NixOS/nixpkgs/issues/188542
36 ln -s /home/julm/documents/thinkpad-x201/gobi $out/lib/firmware/gobi
41 { device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
44 fileSystems."/boot/efi" =
45 { device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
49 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
52 cipher = "aes-xts-plain64";
53 source = "/dev/urandom";
58 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
59 # You should try to make this id unique among your hosts.
60 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
61 networking.hostId = "ce53d0c3";
63 boot.supportedFilesystems = [ "ntfs" "vfat" ];
64 boot.extraModulePackages = [
65 #config.boot.kernelPackages.exfat-nofuse
68 powerManagement.powertop.enable = true;
69 #services.fprintd.enable = true;
72 { device = "${hostName}/root";
76 { device = "${hostName}/nix";
80 { device = "${hostName}/var";