1 { config, lib, pkgs, hostName, ... }:
4 ../../nixos/profiles/acpid.nix
5 ../../nixos/profiles/hardware/thinkpad.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
13 device = "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD1";
14 configurationLimit = 3;
18 { device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
21 fileSystems."/boot/efi" =
22 { device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
26 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
29 cipher = "aes-xts-plain64";
30 source = "/dev/urandom";
35 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
36 # You should try to make this id unique among your hosts.
37 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
38 networking.hostId = "ec2adb40";
40 boot.supportedFilesystems = [ "ntfs" "vfat" ];
41 boot.extraModulePackages = [
42 #config.boot.kernelPackages.exfat-nofuse
45 powerManagement.powertop.enable = true;
48 { device = "${hostName}/root";
52 { device = "${hostName}/nix";
55 fileSystems."/home/sevy" =
56 { device = "${hostName}/home";
59 fileSystems."/home/sevy/Documents" =
60 { device = "${hostName}/home/Documents";
63 fileSystems."/home/sevy/Images" =
64 { device = "${hostName}/home/Images";
67 fileSystems."/home/sevy/Téléchargements" =
68 { device = "${hostName}/home/Downloads";
71 fileSystems."/home/sevy/.thunderbird" =
72 { device = "${hostName}/home/Mails";
75 fileSystems."/home/sevy/Vidéos" =
76 { device = "${hostName}/home/Videos";
80 { device = "${hostName}/var";
83 fileSystems."/var/cache" =
84 { device = "${hostName}/var/cache";
87 fileSystems."/var/log" =
88 { device = "${hostName}/var/log";
91 fileSystems."/var/tmp" =
92 { device = "${hostName}/var/tmp";