]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
git: peek at difftastic and delta
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 enableCompletion = mkDefault true;
7 shellAliases = {
8 afk = "xset s activate dpms force off";
9 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
10 c = "bat";
11 cl = "clear";
12 emacs = "emacsclient --create-frame";
13 grep = "grep --color";
14 j = "sudo journalctl -u";
15 jb = "sudo journalctl -b";
16 ju = "sudo journalctl --user -u";
17 l = "ls -alh";
18 ll = "ls -al";
19 ls = "ls --color=tty";
20 md-toc = "grep '^#\\+' --color";
21 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
22 mem-top = "smem --sort rss --autosize";
23 mpl = "mplayer";
24 nf = "sudo nft list ruleset | less";
25 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
26 nixos-clean = "sudo nix-collect-garbage -d";
27 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
28 nixos-rollback = "sudo nixos-rebuild switch --rollback";
29 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
30 r = "reset";
31 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
32 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
33 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
34 s = "sudo systemctl";
35 st = "sudo systemctl status";
36 t = "tmux";
37 t0 = "tmux new -t 0";
38 t1 = "tmux new -t 1";
39 t2 = "tmux new -t 2";
40 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
41 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
42 u = "systemctl --user";
43 ut = "systemctl --user status";
44 w1 = "watch --color --differences --interval 1";
45 w5 = "watch --color --differences --interval 5";
46 w10 = "watch --color --differences --interval 10";
47 w = "watch --color --differences";
48 watch = "watch --color --differences";
49 ze = "sudo zpool export";
50 zfs-umount = "zfs-unmount";
51 zi = "sudo zpool import";
52 zl = "zfs list";
53 zlb = "zfs list -t bookmarks";
54 zls = "zfs list -t snap";
55 zm = "zfs-mount";
56 zu = "zfs-unmount";
57 };
58 historyControl = [ "erasedups" "ignorespace" ];
59 historyIgnore = [
60 "torify"
61 "mpv"
62 ];
63 historySize = 42000;
64 sessionVariables = {
65 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
66 };
67 initExtra = ''
68 # Alias completion
69 . ${pkgs.complete-alias}/bin/complete_alias
70 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
71
72 shopt -s globstar
73 shopt -s histappend
74 shopt -s histreedit
75 shopt -s histverify
76 # Disable ctrl-s/ctrl-q flow control
77 stty -ixon
78
79 ffmpeg-audio () {
80 for i in "$@"; do
81 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio-only.mkv
82 done
83 }
84 ffmpeg-opus () {
85 for i in "$@"; do
86 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
87 done
88 }
89 opusenc-voice () {
90 find "$@" -depth -type f -print0 | sort -n -z |
91 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
92 test -e "''${0%.*}".opus ||
93 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
94 ' {} \;
95 }
96 ibm-fan () {
97 if [ $# -gt 0 ]
98 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
99 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
100 fi
101 acpi -t
102 }
103 mkcd () {
104 mkdir -p "$1" &&
105 cd "$1"
106 }
107 mkpass () {
108 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
109 }
110 smartctl-tbw () {
111 device=''${1:-/dev/sda}
112 sudo smartctl -A $device |
113 { awk '
114 $0 ~ /Power_On_Hours/ {
115 poh=$10;
116 printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25
117 }
118 $0 ~ /Total_LBAs_Written/ {
119 lbas = $10;
120 bytes = $10 * 512;
121 mb = bytes / 1024^2;
122 gb = bytes / 1024^3;
123 tb = bytes / 1024^4;
124 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
125 printf "mean writes per hour / %.2f", mb/poh
126 }
127 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
128 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
129 $0 ~ /Percentage Used:/ { printf "Percentage_Used / %d\n", int($3) }
130 '; echo; } |
131 sed -e 's:/:@:' |
132 sed -e "s\$^\$$device @ \$" |
133 column -ts@
134 }
135 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
136 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
137 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
138 swaplist () {
139 lastpid=
140 swap=0
141 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
142 while IFS=: read -r file x size x
143 do
144 pid=''${file#/proc/}
145 pid=''${pid%/smaps}
146 size=''${size% kB}
147 size=''${size##* }
148 if test "$pid" = "$lastpid"
149 then swap=$(( swap + size ))
150 else
151 if test "$swap" -gt 0
152 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
153 fi
154 if test "$pid" = self
155 then break
156 else
157 lastpid=$pid
158 swap=$size
159 fi
160 fi
161 done |
162 sort -nk1,1
163 }
164
165 # Recursively mount not-mounted dataset,
166 # loading their keys if needed.
167 zfs-mount () {
168 local d
169 local -
170 set -e
171 for d in $(zfs list -rH -o name "$@"); do
172 mountpoint /mnt/"$d" 2>/dev/null ||
173 sudo zfs mount -l "$d"
174 done
175 }
176 # Recursively unmount dataset,
177 # unloading their keys.
178 zfs-unmount () { sudo zfs unmount -u "$@"; }
179
180 # Create bookmarks for all the snapshots of the given datasets.
181 # Bookmarks are only useful on source datasets
182 # But syncoid --create-bookmark only creates
183 # a bookmark for the latest snapshot,
184 # possibly leaving the *_daily or *_monthly snapshots without a bookmark.
185 zfs-fix-bookmarks () {
186 local d
187 local -
188 set -x
189 for d in "$@"; do
190 for s in $(zfs list -Hrpt snapshot -o name "$d"); do
191 zfs bookmark "$s" "''${s//@/#}"
192 done
193 done
194 }
195
196 # Restore the inheritance of encryptionroot,
197 # usually broken by zfs send --raw.
198 # Note that it needs to decrypt the datasets.
199 zfs-fix-encryptionroot () {
200 local d
201 zfs load-key "$1"
202 for d in $(zfs list -rHo name "$1" | tail -n +2); do
203 echo >&2 "$d"
204 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
205 zfs change-key -li "$d"
206 done
207 }
208
209 # Recursively remove all the snapshots of given datasets
210 zfs-destroy-snapshots () {
211 local d
212 for d in "$@"; do
213 zfs list -t snapshot -rHo name "$d" |
214 xargs --no-run-if-empty -L1 zfs destroy
215 done
216 }
217 '';
218 profileExtra = ''
219 '';
220 };
221 programs.direnv.enableBashIntegration = true;
222 #programs.broot.enableBashIntegration = true;
223 programs.readline = {
224 enable = mkDefault true;
225 includeSystemConfig = true;
226 bindings = {
227 # Up/Down
228 "\\e[A" = "history-search-backward";
229 "\\e[B" = "history-search-forward";
230 "\\eOA" = "history-search-backward";
231 "\\eOB" = "history-search-forward";
232
233 # Ctrl-Left/Ctrl-Right
234 "\\e[1;5C" = "forward-word";
235 "\\e[1;5D" = "backward-word";
236 "\\e[5C" = "forward-word";
237 "\\e[5D" = "backward-word";
238 "\\e\\e[C" = "forward-word";
239 "\\e\\e[D" = "backward-word";
240
241 # Home/End
242 "\\e[1~" = "beginning-of-line";
243 "\\e[4~" = "end-of-line";
244
245 # Delete/Insert
246 "\\e[3~" = "delete-char";
247 "\\e[2~" = "quoted-insert";
248
249 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
250 "\\eOF" = "end-of-line";
251 "\\eOH" = "beginning-of-line";
252
253 # For freebsd console
254 "\\e[F" = "end-of-line";
255 "\\e[H" = "beginning-of-line";
256
257 # $if term=rxvt
258 "\\e[7~" = "beginning-of-line";
259 "\\e[8~" = "end-of-line";
260 "\\eOc" = "forward-word";
261 "\\eOd" = "backward-word";
262 # $endif
263 };
264 variables = {
265 # Be 8 bit clean.
266 input-meta = mkDefault true;
267 output-meta = mkDefault true;
268 colored-completion-prefix = mkDefault true;
269 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
270 echo-control-characters = mkDefault true;
271 mark-symlinked-directories = mkDefault true;
272 menu-complete-display-prefix = mkDefault true;
273 show-all-if-ambiguous = mkDefault true;
274 show-all-if-unmodified = mkDefault true;
275 visible-stats = mkDefault false; # Append char to indicate type
276 enable-bracketed-paste = mkDefault true;
277 };
278 };
279 }