]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/oignon.nix
oignon: clean bitmask-vpn
[julm/julm-nix.git] / hosts / oignon.nix
1 { config, pkgs, lib, inputs, private, hostName, ... }:
2 let
3 inherit (config.users) users;
4 inherit (config.services) davfs2;
5 in
6 {
7 imports = [
8 ../profiles/dnscrypt-proxy2.nix
9 ../profiles/security.nix
10 ../networking/wireguard/wg-intra.nix
11 oignon/hardware.nix
12 oignon/wireguard.nix
13 oignon/tor.nix
14 oignon/backup.nix
15 ];
16
17 home-manager.users.julm = {
18 imports = [
19 ../homes/julm.nix
20 inputs.nix-doom-emacs.hmModule
21 ];
22 host.hardware = ["ThinkPad" "X201"];
23 };
24 systemd.services.home-manager-julm.postStart = ''
25 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
26 '';
27 security.lockKernelModules = false;
28 users.mutableUsers = false;
29 users.users.julm = {
30 isNormalUser = true;
31 uid = 1000;
32 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
33 # which is already world readable.
34 hashedPassword = lib.readFile ../private/world/julm/hashedPassword;
35 extraGroups = [
36 "adbusers"
37 "lp"
38 "networkmanager"
39 "scanner"
40 "tor"
41 "video"
42 "wheel"
43 #"ipfs"
44 davfs2.davGroup
45 #"vboxusers"
46 ];
47 # If created, zfs-mount.service would require:
48 # zfs set overlay=yes ${hostName}/home
49 createHome = false;
50 };
51
52 nix = {
53 extraOptions = ''
54 secret-key-files = ${private}/${hostName}/nix/binary-cache/priv.pem
55 '';
56 autoOptimiseStore = true;
57 gc = {
58 automatic = true;
59 dates = "weekly";
60 options = "--delete-older-than 7d";
61 };
62 nixPath = [
63 "nixpkgs=/etc/nixpkgs"
64 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
65 ];
66 trustedUsers = [ users.julm.name ];
67 binaryCaches = [ "http://nix-localcache.losurdo.wg" ];
68 binaryCachePublicKeys = [ "losurdo.sourcephile.fr-1:XGeaIE2AA2mZskSZ5bIDrfx53q+TDDWJOUEpZDX7los=" ];
69 };
70 documentation = {
71 enable = true;
72 dev.enable = true;
73 doc.enable = true;
74 info.enable = false;
75 man.enable = true;
76 nixos.enable = false;
77 };
78 nix.sshServe = {
79 enable = true;
80 keys = [ (lib.readFile ../private/world/julm/losurdo/ssh.pub) ];
81 };
82 users.users.julm.openssh.authorizedKeys.keys = [
83 (lib.readFile ../private/world/julm/losurdo/ssh.pub)
84 ];
85 services.openssh.openFirewall = false;
86 services.openssh.forwardX11 = true;
87 services.openssh.passwordAuthentication = false;
88
89 nixpkgs.config.allowUnfree = true;
90 environment.etc."nixpkgs".source = pkgs.path;
91 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
92
93 time.timeZone = "Europe/Paris";
94 i18n.defaultLocale = "fr_FR.UTF-8";
95 console.font = "Lat2-Terminus16";
96 console.keyMap = "fr";
97
98 networking = {
99 hostName = hostName;
100 domain = "localdomain";
101 search = [ "sourcephile.fr" ];
102 networkmanager = {
103 enable = true;
104 #dhcp = "dhcpcd";
105 logLevel = "INFO";
106 wifi = {
107 #backend = "iwd";
108 #backend = "wpa_supplicant";
109 powersave = false;
110 };
111 };
112 firewall = {
113 enable = true;
114 allowPing = false;
115 };
116 };
117
118 sound.enable = true;
119 hardware.pulseaudio.enable = true;
120 hardware.sane.enable = true;
121 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
122
123 environment.variables = {
124 EDITOR = "vim";
125 PAGER = "less -R";
126 SYSTEMD_LESS = "FKMRX";
127 };
128 environment.systemPackages = [
129 pkgs.mkpasswd
130 pkgs.gdb
131 pkgs.riseup-vpn
132 #pkgs.calyx-vpn
133 ];
134
135 programs = {
136 bash = {
137 interactiveShellInit = ''
138 bind '"\e[A":history-search-backward'
139 bind '"\e[B":history-search-forward'
140
141 # Ignore duplicate commands, ignore commands starting with a space
142 export HISTCONTROL=erasedups:ignorespace
143 export HISTSIZE=42000
144 # Append to the history instead of overwriting (good for multiple connections)
145 shopt -s histappend
146
147 # Utilities
148 mkcd () { mkdir -p "$1"; cd "$1"; }
149 fan () {
150 if [ $# -gt 0 ]
151 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
152 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
153 fi
154 acpi -t
155 }
156 '';
157 shellAliases = {
158 cl = "clear";
159 grep = "grep --color";
160 l = "ls -alh";
161 ll = "ls -al";
162 ls = "ls --color=tty";
163 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
164
165 s="sudo systemctl";
166 st="sudo systemctl status";
167 u="systemctl --user";
168 j="sudo journalctl -u";
169 jb="sudo journalctl -b";
170
171 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
172 mv = "mv -i";
173 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
174 };
175 };
176 dconf.enable = true;
177 mtr.enable = true;
178 };
179
180 services.avahi = {
181 enable = true;
182 nssmdns = true;
183 openFirewall = false;
184 publish = {
185 enable = false;
186 };
187 };
188 services.davfs2 = {
189 enable = true;
190 extraConfig = ''
191 '';
192 };
193 fileSystems."/home/julm/mnt/ilico/severine" = {
194 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
195 fsType = "davfs";
196 options =
197 let conf = pkgs.writeText "davfs2.conf" ''
198 backup_dir /home/julm/documents/backup/ilico/severine
199 cache_dir /home/julm/.cache/davfs2/ilico/severine
200 ''; in
201 [ "conf=${conf}" "user" "noexec" "nosuid" "noauto" ]; # "x-systemd.automount"
202 };
203 services.dbus = {
204 packages = [ pkgs.gnome3.dconf ];
205 };
206 services.gvfs = {
207 enable = true;
208 };
209 services.ipfs = {
210 #enable = true;
211 defaultMode = "online";
212 autoMount = true;
213 enableGC = true;
214 localDiscovery = false;
215 extraConfig = {
216 Datastore.StorageMax = "10GB";
217 Discovery.MDNS.Enabled = false;
218 #Bootstrap = [
219 #];
220 #Swarm.AddrFilters = null;
221 };
222 startWhenNeeded = true;
223 };
224 services.journald = {
225 extraConfig = ''
226 Compress=true
227 MaxRetentionSec=1month
228 Storage=persistent
229 SystemMaxUse=100M
230 '';
231 };
232 services.printing = {
233 enable = true;
234 drivers = [
235 pkgs.gutenprint
236 pkgs.hplip
237 ];
238 };
239 services.udev = {
240 packages = [
241 # Allow members of the "adbusers" group to mount Android devices via MTP.
242 pkgs.android-udev-rules
243 # Allow the console user access the Yubikey USB device node,
244 # needed for challenge/response to work correctly.
245 pkgs.yubikey-personalization
246 ];
247 };
248 services.xserver = {
249 enable = true;
250 layout = "fr";
251 xkbOptions = "eurosign:e";
252 libinput.enable = true;
253 desktopManager = {
254 session = [
255 # Let the session be generated by home-manager
256 { name = "home-manager";
257 start = ''
258 ${pkgs.runtimeShell} $HOME/.hm-xsession &
259 waitPID=$!
260 '';
261 }
262 ];
263 };
264 displayManager = {
265 defaultSession = "home-manager";
266 #defaultSession = "none+xmonad";
267 autoLogin = {
268 enable = true;
269 user = users.julm.name;
270 };
271 };
272 };
273
274 systemd.coredump.enable = true;
275 #environment.enableDebugInfo = true;
276
277 # This value determines the NixOS release with which your system is to be
278 # compatible, in order to avoid breaking some software such as database
279 # servers. You should change this only after NixOS release notes say you should.
280 system.stateVersion = "20.09"; # Did you read the comment?
281 }