]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: alias: add nix-du-svg
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 shellAliases = {
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
8 c = "bat";
9 cl = "clear";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
13 g = "git";
14 gg = "git grep";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 ju = "sudo journalctl --user -u";
19 l = "ls -alh";
20 ll = "ls -al";
21 ls = "ls --color=tty";
22 md-toc = "grep '^#\\+' --color";
23 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
24 mem-top = "smem --sort rss --autosize";
25 mpl = "mplayer";
26 nf = "sudo nft list ruleset | less";
27 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
28 nixos-clean = "sudo nix-collect-garbage -d";
29 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
30 nixos-rollback = "sudo nixos-rebuild switch --rollback";
31 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
32 r = "reset";
33 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
34 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
35 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
36 s = "sudo systemctl";
37 st = "sudo systemctl status";
38 t = "tmux";
39 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
40 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
41 u = "systemctl --user";
42 ut = "systemctl --user status";
43 w1 = "watch --color --differences --interval 1";
44 w5 = "watch --color --differences --interval 5";
45 w10 = "watch --color --differences --interval 10";
46 w = "watch --color --differences";
47 watch = "watch --color --differences";
48 zfs-umount = "zfs-unmount";
49 };
50 sessionVariables = {
51 HISTCONTROL = "erasedups:ignorespace";
52 HISTSIZE = "42000";
53 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
54 };
55 initExtra = ''
56 # Alias completion
57 . ${pkgs.complete-alias}/bin/complete_alias
58 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
59
60 shopt -s globstar
61 shopt -s histappend
62 shopt -s histreedit
63 shopt -s histverify
64 # Disable ctrl-s/ctrl-q flow control
65 stty -ixon
66
67 ibm-fan () {
68 if [ $# -gt 0 ]
69 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
70 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
71 fi
72 acpi -t
73 }
74 mkcd () {
75 mkdir -p "$1" &&
76 cd "$1"
77 }
78 mkpass () {
79 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
80 }
81 opusenc-voice () {
82 find "$@" -depth -type f -print0 | sort -n -z |
83 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
84 test -e "''${0%.*}".opus ||
85 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
86 ' {} \;
87 }
88 smartctl-tbw () {
89 device=''${1:-/dev/sda}
90 sudo smartctl -A $device |
91 { awk '
92 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
93 $0 ~ /Total_LBAs_Written/ {
94 lbas = $10;
95 bytes = $10 * 512;
96 mb = bytes / 1024^2;
97 gb = bytes / 1024^3;
98 tb = bytes / 1024^4;
99 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
100 printf "mean writes per hour: / %.2f", mb/poh
101 }
102 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
103 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
104 '; echo; } |
105 sed -e 's:/:@:' |
106 sed -e "s\$^\$$device @ \$" |
107 column -ts@
108 }
109 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
110 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
111 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
112 swaplist () {
113 lastpid=
114 swap=0
115 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
116 while IFS=: read -r file x size x
117 do
118 pid=''${file#/proc/}
119 pid=''${pid%/smaps}
120 size=''${size% kB}
121 size=''${size##* }
122 if test "$pid" = "$lastpid"
123 then swap=$(( swap + size ))
124 else
125 if test "$swap" -gt 0
126 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
127 fi
128 if test "$pid" = self
129 then break
130 else
131 lastpid=$pid
132 swap=$size
133 fi
134 fi
135 done |
136 sort -nk1,1
137 }
138 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
139 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
140
141 # Recursively mount not-mounted dataset,
142 # loading their keys if needed.
143 zfs-mount () {
144 local d
145 for d in $(zfs list -rH -o name "$@"); do
146 mountpoint /mnt/"$d" 2>/dev/null ||
147 sudo zfs mount -l "$d"
148 done
149 }
150 # Recursively unmount dataset,
151 # unloading their keys.
152 zfs-unmount () { sudo zfs unmount -u "$@"; }
153
154 # Restore the inheritance of encryptionroot,
155 # usually broken by zfs send --raw.
156 # Note that it needs to decrypt the datasets.
157 zfs-fix-encryptionroot () {
158 local d
159 zfs load-key "$1"
160 for d in $(zfs list -rHo name "$1" | tail -n +2); do
161 echo >&2 "$d"
162 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
163 zfs change-key -li "$d"
164 done
165 }
166
167 # Recursively remove all the snapshots of given datasets
168 zfs-destroy-snapshots () {
169 local d
170 for d in "$@"; do
171 zfs list -t snapshot -rHo name "$d" |
172 xargs --no-run-if-empty -L1 zfs destroy
173 done
174 }
175 '';
176 profileExtra = ''
177 '';
178 };
179 programs.direnv.enableBashIntegration = true;
180 #programs.broot.enableBashIntegration = true;
181 programs.readline = {
182 enable = mkDefault true;
183 includeSystemConfig = true;
184 bindings = {
185 # Up/Down
186 "\\e[A" = "history-search-backward";
187 "\\e[B" = "history-search-forward";
188 "\\eOA" = "history-search-backward";
189 "\\eOB" = "history-search-forward";
190
191 # Ctrl-Left/Ctrl-Right
192 "\\e[1;5C" = "forward-word";
193 "\\e[1;5D" = "backward-word";
194 "\\e[5C" = "forward-word";
195 "\\e[5D" = "backward-word";
196 "\\e\\e[C" = "forward-word";
197 "\\e\\e[D" = "backward-word";
198
199 # Home/End
200 "\\e[1~" = "beginning-of-line";
201 "\\e[4~" = "end-of-line";
202
203 # Delete/Insert
204 "\\e[3~" = "delete-char";
205 "\\e[2~" = "quoted-insert";
206
207 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
208 "\\eOF" = "end-of-line";
209 "\\eOH" = "beginning-of-line";
210
211 # For freebsd console
212 "\\e[F" = "end-of-line";
213 "\\e[H" = "beginning-of-line";
214
215 # $if term=rxvt
216 "\\e[7~" = "beginning-of-line";
217 "\\e[8~" = "end-of-line";
218 "\\eOc" = "forward-word";
219 "\\eOd" = "backward-word";
220 # $endif
221 };
222 variables = {
223 # Be 8 bit clean.
224 input-meta = mkDefault true;
225 output-meta = mkDefault true;
226 colored-completion-prefix = mkDefault true;
227 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
228 echo-control-characters = mkDefault true;
229 mark-symlinked-directories = mkDefault true;
230 menu-complete-display-prefix = mkDefault true;
231 show-all-if-ambiguous = mkDefault true;
232 show-all-if-unmodified = mkDefault true;
233 visible-stats = mkDefault false; # Append char to indicate type
234 enable-bracketed-paste = mkDefault true;
235 };
236 };
237 }