1 { pkgs, config, hostName, ... }:
3 inherit (config) networking;
4 inherit (config.services) nginx;
8 ../../nixos/profiles/services/nginx.nix
11 networking.nftables.ruleset = ''
14 tcp dport { http } counter accept comment "HTTP"
17 tcp dport { http } counter accept comment "HTTP"
22 fileSystems."/var/lib/nginx" = {
23 device = "${hostName}/var/www";
30 package = pkgs.nginx.override {
31 modules = with pkgs.nginxModules; [
37 addresses = [ "127.0.0.1:53" ];
43 # Connection closed without response