5 "https://nix-community.cachix.org"
7 extra-trusted-public-keys = [
8 "nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
14 doom-emacs.flake = false;
15 doom-emacs.url = "github:hlissner/doom-emacs";
16 home-manager.inputs.nixpkgs.follows = "nixpkgs";
17 home-manager.url = "github:nix-community/home-manager/release-24.05";
18 nix-formatter-pack.inputs.nixpkgs.follows = "nixpkgs";
19 nix-formatter-pack.url = "github:Gerschtli/nix-formatter-pack";
20 nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.05";
21 git-hooks.inputs.nixpkgs.follows = "nixpkgs";
22 git-hooks.inputs.nixpkgs-stable.follows = "nixpkgs";
23 git-hooks.url = "github:cachix/git-hooks.nix";
28 remoteNixpkgsPatches = import nixpkgs/patches.nix;
29 localNixpkgsPatches = [
31 originPkgs = inputs.nixpkgs.legacyPackages."x86_64-linux";
32 nixpkgsPath = originPkgs.applyPatches {
33 name = "nixpkgs-patched";
34 src = inputs.nixpkgs.outPath;
35 patches = map originPkgs.fetchpatch remoteNixpkgsPatches ++ localNixpkgsPatches;
37 patch=$(printf '%s\n' ${builtins.concatStringsSep " "
38 (map (p: p.sha256) remoteNixpkgsPatches ++ localNixpkgsPatches)} |
39 sort | sha256sum | cut -c -7)
40 echo "-patch-$patch" >.version-suffix
43 profile = "/nix/var/nix/profiles/system";
44 inherit (inputs.nixpkgs) lib;
46 import nixpkgs/overlays.nix ++ [
48 #nixosSystem = lib.nixosSystem;
49 nixosSystem = import (nixpkgsPath + "/nixos/lib/eval-config.nix");
50 forAllSystems = f: lib.genAttrs lib.systems.flakeExposed (system: f rec {
52 #pkgs = inputs.nixpkgs.legacyPackages.${system};
53 pkgs = import nixpkgsPath {
55 overlays = overlays system;
58 self = with lib.fileset; toSource {
61 let exts = [ "clear" "conf" "cred" "crt" "css" "el" "hs" "json" "nix" "patch" "pem" "pub" "sh" "theme" "vim" ]; in
63 (fileFilter (file: lib.any file.hasExt exts) ./home-manager)
64 (fileFilter (file: lib.any file.hasExt exts) ./homes)
65 (fileFilter (file: lib.any file.hasExt exts) ./hosts)
66 (fileFilter (file: lib.any file.hasExt exts) ./nixos)
67 (fileFilter (file: lib.any file.hasExt exts) ./nixpkgs)
68 (fileFilter (file: lib.any file.hasExt exts) ./share)
69 (fileFilter (file: lib.any file.hasExt exts) ./users)
75 # nix -L build .#hello
76 packages = forAllSystems ({ pkgs, ... }: pkgs);
78 # nix -L build .#nixosConfigurations.oignon.config.system.build.toplevel
79 # nix -L build .#nixosConfigurations.oignon.config.boot.kernelPackages.kernel.configfile
80 # nix -L build .#nixosConfigurations.oignon.pkgs.hello
81 # nix eval --raw .#nixosConfigurations.oignon.config.networking.nftables.ruleset
82 nixosConfigurations = lib.genAttrs
83 (builtins.attrNames (lib.filterAttrs (_n: v: v == "directory") (builtins.readDir (self + "/hosts"))))
84 (hostName: nixosSystem {
87 # Required to avoid infinite recursion
88 # when `inputs` is used in `imports`.
93 (import (self + "/hosts/${hostName}.nix"))
97 hosts = nixosConfigurations;
98 host = nixosConfigurations.${hostName}._module.args;
100 nixpkgs.overlays = overlays config.nixpkgs.hostPlatform.system;
101 nixpkgs.config.permittedInsecurePackages = [
102 # Still needed for chatty
103 # See https://github.com/NixOS/nixpkgs/pull/334638#issuecomment-2289025802%3E
104 # and https://gitlab.gnome.org/World/Chatty/-/issues/932
107 nixpkgs.config.allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [
117 inputs.home-manager.nixosModules.home-manager
119 home-manager.useGlobalPkgs = true;
120 home-manager.useUserPackages = true;
121 home-manager.verbose = true;
122 #home-manager.force = true;
123 home-manager.backupFileExtension = "old";
124 home-manager.extraSpecialArgs = {
125 inherit hostName inputs;
131 # nix -L develop or direnv allow
132 devShells = forAllSystems ({ pkgs, system, ... }:
134 default = pkgs.callPackage (self + "/shell.nix")
136 inherit pkgs inputs system nixpkgsPath;
137 inherit (checks.${system}.git-hooks-check) shellHook;
142 # nix -L run .#oignon.switch
143 apps = forAllSystems ({ pkgs, system, ... }:
146 (hostName: { config, ... }:
148 inherit (config.system) build;
149 scriptApp = scriptName: ps: script: {
151 program = (pkgs.writeShellScript "${hostName}-${scriptName}" ''
152 export PATH="${lib.makeBinPath ([ pkgs.coreutils ] ++ ps)}:$PATH"
159 # Example: nix run .#aubergine.switch
160 "switch" = scriptApp "switch" [ ] ''
163 chmod -R g-rwx,o-rwx **/*.gpg
164 trap 'git reset **/*.gpg' EXIT
165 git rm -rf --cached --ignore-unmatch **/*.gpg # prevent copying to /nix/store
167 nix-store --add-root hosts/${hostName}.nixpkgs --indirect --realise ${nixpkgsPath}
168 nix-store --add-root hosts/${hostName}.root --indirect --realise ${build.toplevel}
170 nix copy --to "ssh://${config.install.target}?''${targetStore-}"${lib.optionalString config.install.substituteOnDestination " --substitute-on-destination"} ${build.toplevel}
172 if ssh ${config.install.target} set -x ';' \
173 systemctl reset-failed nixos-fallback '2>/dev/null' ';' \
174 test "''${NO_NIXOS_FALLBACK:+set}" '||' \
175 systemd-run -u nixos-fallback --description=nixos-fallback /bin/sh -xc '''\'''
176 PATH=${with pkgs; lib.makeBinPath [ coreutils nix systemd ]}
178 ${profile}/bin/switch-to-configuration switch
181 ${build.toplevel}/bin/switch-to-configuration test
183 ssh ${config.install.target} -o ControlPath=none set -x ';' \
184 systemctl stop nixos-fallback.service ';' \
185 nix-env --profile ${profile} --set '${build.toplevel}' ';' \
186 ${build.toplevel}/bin/switch-to-configuration boot '&&' \
187 nix-env --delete-generations 7d --profile ${profile}
190 echo WARNING: switch-to-configuration was not registered at boot
192 ssh ${config.install.target} -o ControlPath=none set -x ';' \
193 systemctl stop nixos-fallback.service
198 nixosConfigurations);
201 checks = forAllSystems (args: with args; {
202 git-hooks-check = inputs.git-hooks.lib.${system}.run {
205 nixpkgs-fmt.enable = true;
211 formatter = forAllSystems ({ pkgs, ... }:
212 inputs.nix-formatter-pack.lib.mkFormatter {
216 deadnix.enable = true;
217 nixpkgs-fmt.enable = true;
218 statix.enable = true;