]> Git — Sourcephile - julm/julm-nix.git/blob - homes.nix
home-manager: fix standalone use
[julm/julm-nix.git] / homes.nix
1 # This file is only used when home-manager
2 # is called manually, not when integrated into NixOS.
3 with builtins;
4 { pkgs, lib, config, ... }:
5 {
6 imports = [
7 (./homes + "/${getEnv "USER"}.nix")
8 #homes/softwares.nix
9 #homes/options.nix
10 ];
11 config = {
12 nixpkgs.overlays = import <nixpkgs-overlays>;
13 home.stateVersion = lib.mkDefault "20.09";
14 home.username = lib.mkDefault (getEnv "USER");
15 home.homeDirectory = lib.mkDefault "/home/${config.home.username}";
16 };
17 }