]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/hardware/apu6b4.nix
apu6b4: fix missing config
[julm/julm-nix.git] / nixos / profiles / hardware / apu6b4.nix
1 { pkgs, lib, config, ... }:
2 with lib;
3 {
4
5 nixpkgs.hostPlatform = {
6 system = "x86_64-linux";
7 config = "x86_64-unknown-linux-gnu";
8 };
9 _module.args.CPUs = 4;
10 hardware.cpu.amd.updateMicrocode = mkDefault config.hardware.enableRedistributableFirmware;
11 powerManagement.cpuFreqGovernor = mkDefault "ondemand";
12
13 # Too CPU hungry for this hardware, for too little MiB saved
14 nix.settings.auto-optimise-store = false;
15
16 # https://insanity.industries/post/sata-power-consumption/
17 services.udev.extraRules = ''
18 SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
19 '';
20
21 boot.loader = {
22 grub = {
23 enable = true;
24 copyKernels = true;
25 configurationLimit = mkDefault 1;
26 # efiSupport = true;
27 # In case canTouchEfiVariables doesn't work
28 #efiInstallAsRemovable = true;
29 devices = [
30 # Completed in the importing configuration
31 ];
32 /*
33 mirroredBoots = [
34 { devices = [ "${disk_id}" ];
35 path = "/boot${bootnum}";
36 }
37 ];
38 */
39 };
40 /*
41 efi = {
42 canTouchEfiVariables = true;
43 efiSysMountPoint = "/boot/efi";
44 };
45 */
46 };
47
48 boot.initrd = {
49 availableKernelModules = [
50 "ahci"
51 "ehci_pci"
52 "sd_mod"
53 "sg"
54 "uas"
55 ];
56 kernelModules = [
57 # Ethernet driver
58 "igb"
59 # Enable to switch to stage-2 from the SD card
60 "sdhci_pci"
61 ];
62 };
63
64 boot.consoleLogLevel = mkDefault 7;
65 boot.kernelParams = [
66 "gfxpayload=text"
67 "console=ttyS0,115200n8"
68 # Use arc_summary to print stats
69 #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
70 ];
71
72 environment.systemPackages = [
73 pkgs.flashrom
74 pkgs.pciutils
75 ];
76 }