5 enable = mkDefault true;
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
20 ls = "ls --color=tty";
21 md-toc = "grep '^#\\+' --color";
22 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
23 mem-top = "smem --sort rss --autosize";
25 nf = "sudo nft list ruleset | less";
26 nixos-clean = "sudo nix-collect-garbage -d";
27 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
28 nixos-rollback = "sudo nixos-rebuild switch --rollback";
29 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
31 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
33 st = "sudo systemctl status";
34 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
35 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
36 u = "systemctl --user";
37 ut = "systemctl --user status";
38 w1 = "watch --color --differences --interval 1";
39 w5 = "watch --color --differences --interval 5";
40 w10 = "watch --color --differences --interval 10";
41 w = "watch --color --differences";
42 watch = "watch --color --differences";
44 zfs-umount = "zfs-unmount";
47 HISTCONTROL = "erasedups:ignorespace";
49 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
53 . ${pkgs.complete-alias}/bin/complete_alias
54 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
60 # Disable ctrl-s/ctrl-q flow control
65 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
66 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
75 device=''${1:-/dev/sda}
76 sudo smartctl -A $device |
78 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
79 $0 ~ /Total_LBAs_Written/ {
85 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
86 printf "mean writes per hour: / %.2f", mb/poh
88 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
89 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
92 sed -e "s\$^\$$device @ \$" |
95 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
96 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
97 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
101 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
102 while IFS=: read -r file x size x
108 if test "$pid" = "$lastpid"
109 then swap=$(( swap + size ))
111 if test "$swap" -gt 0
112 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
114 if test "$pid" = self
124 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
125 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
126 zfs-mount () { for d in $(zfs list -rH -o name "$@"); do sudo zfs mount -l "$d"; done; }
127 zfs-unmount () { sudo zfs unmount -u "$@"; }
132 programs.direnv.enableBashIntegration = true;
133 #programs.broot.enableBashIntegration = true;
134 programs.readline = {
135 enable = mkDefault true;
136 includeSystemConfig = true;
139 "\\e[A" = "history-search-backward";
140 "\\e[B" = "history-search-forward";
142 # Ctrl-Left/Ctrl-Right
143 "\\e[1;5C" = "forward-word";
144 "\\e[1;5D" = "backward-word";
145 "\\e[5C" = "forward-word";
146 "\\e[5D" = "backward-word";
147 "\\e\\e[C" = "forward-word";
148 "\\e\\e[D" = "backward-word";
151 "\\e[1~" = "beginning-of-line";
152 "\\e[4~" = "end-of-line";
155 "\\e[3~" = "delete-char";
156 "\\e[2~" = "quoted-insert";
158 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
159 "\\eOF" = "end-of-line";
160 "\\eOH" = "beginning-of-line";
162 # For freebsd console
163 "\\e[F" = "end-of-line";
164 "\\e[H" = "beginning-of-line";
167 "\\e[7~" = "beginning-of-line";
168 "\\e[8~" = "end-of-line";
169 "\\eOc" = "forward-word";
170 "\\eOd" = "backward-word";
175 input-meta = mkDefault true;
176 output-meta = mkDefault true;
177 colored-completion-prefix = mkDefault true;
178 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
179 echo-control-characters = mkDefault true;
180 mark-symlinked-directories = mkDefault true;
181 menu-complete-display-prefix = mkDefault true;
182 show-all-if-ambiguous = mkDefault true;
183 show-all-if-unmodified = mkDefault true;
184 visible-stats = mkDefault false; # Append char to indicate type