1 { config, pkgs, inputs, machineName, ... }:
3 inherit (config.users) users;
10 users.mutableUsers = false;
14 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
15 # which is already world readable.
16 hashedPassword = builtins.readFile ../secrets/julm/hashedPassword;
23 # If created, zfs-mount.service would require:
24 # zfs set overlay=yes ${machineName}/home
30 auto-optimise-store = true
35 options = "--delete-older-than 7d";
38 "nixpkgs=/etc/nixpkgs"
39 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
41 trustedUsers = [ users.julm.name ];
43 environment.etc."nixpkgs".source = pkgs.path;
44 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
50 time.timeZone = "Europe/Paris";
51 i18n.defaultLocale = "fr_FR.UTF-8";
52 console.font = "Lat2-Terminus16";
53 console.keyMap = "fr";
56 hostName = machineName;
57 domain = "localdomain";
64 #backend = "wpa_supplicant";
74 hardware.pulseaudio.enable = true;
76 environment.variables = {
79 SYSTEMD_LESS = "FKMRX";
81 environment.systemPackages = with pkgs; [
131 interactiveShellInit = ''
132 bind '"\e[A":history-search-backward'
133 bind '"\e[B":history-search-forward'
135 # Ignore duplicate commands, ignore commands starting with a space
136 export HISTCONTROL=erasedups:ignorespace
137 export HISTSIZE=42000
138 # Append to the history instead of overwriting (good for multiple connections)
145 ls = "ls --color=tty";
146 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
149 st="sudo systemctl status";
150 s-u="systemctl --user";
151 j="sudo journalctl -u";
153 nix-clean="sudo nix-collect-garbage -d";
154 nix-catalog="sudo nix-channel --list";
155 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
156 nix-rollback="sudo nixos-rebuild switch --rollback";
157 nix-update="sudo nix-channel --update";
158 nix-upgrade="sudo nixos-rebuild switch";
159 nix-upstream="sudo nix-channel --list";
160 nix-config="gvim ~/.config/nixos/*.nix";
166 enableSSHSupport = true;
177 packages = [ pkgs.gnome3.dconf ];
185 MaxRetentionSec=1month
193 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
204 extraArgs = [ "--verbose" ];
206 "${machineName}/home" = {
215 "${machineName}/var" = {
229 xkbOptions = "eurosign:e";
230 libinput.enable = true;
233 # Let the session be generated by home-manager
234 { name = "home-manager";
236 ${pkgs.runtimeShell} $HOME/.hm-xsession &
245 pkgs.xfce.thunar-archive-plugin
249 xterm.enable = false;
252 defaultSession = "home-manager";
253 #defaultSession = "none+xmonad";
256 user = users.julm.name;
262 #virtualisation.virtualbox.host.enable = true;
264 # This value determines the NixOS release with which your system is to be
265 # compatible, in order to avoid breaking some software such as database
266 # servers. You should change this only after NixOS release notes say you should.
267 system.stateVersion = "20.09"; # Did you read the comment?