2 with (import ./names-and-numbers.nix);
4 inherit (config.users) users;
7 networking.nftables.ruleset = ''
10 iifname ${lteIface} jump input-net
11 iifname ${lteIface} log level warn prefix "input-net: " counter drop
14 ip daddr 10.151.0.1 tcp dport 8080 counter accept \
15 comment "mmsd: Prixtel/SFR"
18 oifname ${lteIface} jump output-net
19 oifname ${lteIface} log level warn prefix "output-net: " counter drop
21 chain forward-to-net {
23 chain forward-from-net {
25 chain forward-to-net { }
26 chain forward-from-net { }
28 iifname { ${wifiIface}, ${eth1Iface}, ${eth2Iface}, ${eth3Iface} } oifname ${lteIface} goto forward-to-net
29 iifname ${lteIface} oifname { ${wifiIface}, ${eth1Iface}, ${eth2Iface}, ${eth3Iface} } goto forward-from-net
34 iifname { ${wifiIface}, ${eth1Iface}, ${eth2Iface}, ${eth3Iface} } oifname ${lteIface} masquerade
38 services.mmsd.enable = true;
39 services.mmsd.extraArgs = [ "--debug" ];
40 systemd.services.NetworkManager.wants = [ "ModemManager.service" ];
41 services.dbus.packages = [ pkgs.dconf ];
42 programs.dconf.enable = true;
43 environment.etc."NetworkManager/system-connections/Prixtel.nmconnection" = {
48 uuid=b223f550-dff1-4ba3-9755-cd4557faaa5a
62 dhcp-send-hostname=false
66 addr-gen-mode=stable-privacy
68 dhcp-send-hostname=false
73 environment.systemPackages = [
74 pkgs.modem-manager-gui
77 pkgs.gnome.gnome-contacts
81 # https://gitlab.com/mobian1/callaudiod/-/issues/26
82 # https://gitlab.com/mobian1/callaudiod/-/issues/27