4 ../../nixos/profiles/hardware/X200.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
12 device = "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD1";
13 configurationLimit = 3;
18 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
21 fileSystems."/boot/efi" =
23 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
28 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
31 cipher = "aes-xts-plain64";
32 source = "/dev/urandom";
37 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
38 # You should try to make this id unique among your hosts.
39 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
40 networking.hostId = "ec2adb40";
42 boot.supportedFilesystems = [ "ntfs" "vfat" ];
43 boot.extraModulePackages = [
44 #config.boot.kernelPackages.exfat-nofuse
47 powerManagement.powertop.enable = true;
51 device = "${hostName}/root";
56 device = "${hostName}/nix";
59 fileSystems."/home/sevy" =
61 device = "${hostName}/home";
64 fileSystems."/home/sevy/Documents" =
66 device = "${hostName}/home/Documents";
69 fileSystems."/home/sevy/Images" =
71 device = "${hostName}/home/Images";
74 fileSystems."/home/sevy/Téléchargements" =
76 device = "${hostName}/home/Downloads";
79 fileSystems."/home/sevy/.thunderbird" =
81 device = "${hostName}/home/Mails";
84 fileSystems."/home/sevy/Vidéos" =
86 device = "${hostName}/home/Videos";
91 device = "${hostName}/var";
94 fileSystems."/var/cache" =
96 device = "${hostName}/var/cache";
99 fileSystems."/var/log" =
101 device = "${hostName}/var/log";
104 fileSystems."/var/tmp" =
106 device = "${hostName}/var/tmp";