5 nixpkgs.hostPlatform = {
6 system = "x86_64-linux";
7 config = "x86_64-unknown-linux-gnu";
10 hardware.cpu.amd.updateMicrocode = true;
11 powerManagement.cpuFreqGovernor = mkDefault "ondemand";
13 # Too CPU hungry for this hardware, for too little Mio saved
14 nix.settings.auto-optimise-store = false;
16 # https://insanity.industries/post/sata-power-consumption/
17 services.udev.extraRules = ''
18 SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
26 configurationLimit = mkDefault 1;
28 # In case canTouchEfiVariables doesn't work
29 #efiInstallAsRemovable = true;
31 # Completed in the importing configuration
35 { devices = [ "${disk_id}" ];
36 path = "/boot${bootnum}";
43 canTouchEfiVariables = true;
44 efiSysMountPoint = "/boot/efi";
50 availableKernelModules = [
60 # Enable to switch to stage-2 from the SD card
65 boot.consoleLogLevel = mkDefault 7;
68 "console=ttyS0,115200n8"
69 # Use arc_summary to print stats
70 #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
73 environment.systemPackages = [