]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/hardware/apu6b4.nix
sshd: use LoadCredentialEncrypted=
[julm/julm-nix.git] / nixos / profiles / hardware / apu6b4.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4
5 nixpkgs.hostPlatform = {
6 system = "x86_64-linux";
7 config = "x86_64-unknown-linux-gnu";
8 };
9 _module.args.CPUs = 4;
10 hardware.cpu.amd.updateMicrocode = true;
11 powerManagement.cpuFreqGovernor = mkDefault "ondemand";
12
13 # Too CPU hungry for this hardware, for too little Mio saved
14 nix.settings.auto-optimise-store = false;
15
16 # https://insanity.industries/post/sata-power-consumption/
17 services.udev.extraRules = ''
18 SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
19 '';
20
21 boot.loader = {
22 grub = {
23 enable = true;
24 version = 2;
25 copyKernels = true;
26 configurationLimit = mkDefault 1;
27 # efiSupport = true;
28 # In case canTouchEfiVariables doesn't work
29 #efiInstallAsRemovable = true;
30 devices = [
31 # Completed in the importing configuration
32 ];
33 /*
34 mirroredBoots = [
35 { devices = [ "${disk_id}" ];
36 path = "/boot${bootnum}";
37 }
38 ];
39 */
40 };
41 /*
42 efi = {
43 canTouchEfiVariables = true;
44 efiSysMountPoint = "/boot/efi";
45 };
46 */
47 };
48
49 boot.initrd = {
50 availableKernelModules = [
51 "ahci"
52 "ehci_pci"
53 "sd_mod"
54 "sg"
55 "uas"
56 ];
57 kernelModules = [
58 # Ethernet driver
59 "igb"
60 # Enable to switch to stage-2 from the SD card
61 "sdhci_pci"
62 ];
63 };
64
65 boot.consoleLogLevel = mkDefault 7;
66 boot.kernelParams = [
67 "gfxpayload=text"
68 "console=ttyS0,115200n8"
69 # Use arc_summary to print stats
70 #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
71 ];
72
73 environment.systemPackages = [
74 pkgs.flashrom
75 pkgs.pciutils
76 ];
77 }