]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/networking/remote.nix
sshd: use LoadCredentialEncrypted=
[julm/julm-nix.git] / nixos / profiles / networking / remote.nix
1 {
2 imports = [
3 ./ssh.nix
4 ];
5 # On a remote headless server: always reboot on a kernel panic,
6 # to not have to physically go power cycle the server.
7 # Which may happen for instance if the wrong ZFS password is used
8 # but the boot is manually forced to continue.
9 # Using kernelParams instead of kernel.sysctl
10 # sets this up as soon as the initrd.
11 boot.kernelParams = [ "panic=10" ];
12
13 programs.gnupg.agent.pinentryFlavor = "curses";
14
15 # Always try to start all the units (default.target)
16 # because systemd's emergency shell does not try to start sshd.
17 # https://wiki.archlinux.org/index.php/systemd#Disable_emergency_mode_on_remote_host
18 systemd.enableEmergencyMode = false;
19 }