1 { config, lib, pkgs, hostName, ... }:
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
12 canTouchEfiVariables = true;
13 efiSysMountPoint = "/boot/efi";
20 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
21 "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
23 configurationLimit = 9;
27 #enableCryptodisk = true;
29 boot.tmpOnTmpfs = true;
32 { device = "/dev/disk/by-partlabel/${hostName}_sd_root";
35 fileSystems."/boot/efi" =
36 { device = "/dev/disk/by-partlabel/${hostName}_sd_efi";
41 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
44 cipher = "aes-xts-plain64";
45 source = "/dev/urandom";
51 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
52 # You should try to make this id unique among your hosts.
53 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
54 networking.hostId = "408a404a";
56 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
57 boot.extraModulePackages = [
58 #config.boot.kernelPackages.exfat-nofuse
61 powerManagement.powertop.enable = true;
62 #services.fprintd.enable = true;
66 { device = "${hostName}/root";
70 { device = "${hostName}/nix";
74 { device = "${hostName}/var";
79 hardware.pulseaudio.enable = lib.mkDefault true;
80 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;