1 { config, lib, pkgs, hostName, ... }:
4 ../../nixos/profiles/acpid.nix
5 ../../nixos/profiles/hardware/thinkpad.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
12 canTouchEfiVariables = true;
13 efiSysMountPoint = "/boot/efi";
19 device = "/dev/disk/by-id/ata-Samsung_SSD_850_PRO_128GB_S1SMNSAFC36436X";
20 configurationLimit = 3;
24 #enableCryptodisk = true;
28 { device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
31 fileSystems."/boot/efi" =
32 { device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
36 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
39 cipher = "aes-xts-plain64";
40 source = "/dev/urandom";
45 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
46 # You should try to make this id unique among your hosts.
47 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
48 networking.hostId = "ce53d0c3";
50 boot.supportedFilesystems = [ "ntfs" "vfat" ];
51 boot.extraModulePackages = [
52 #config.boot.kernelPackages.exfat-nofuse
55 powerManagement.powertop.enable = true;
56 #services.fprintd.enable = true;
59 { device = "${hostName}/root";
63 { device = "${hostName}/nix";
67 { device = "${hostName}/var";