]> Git — Sourcephile - julm/julm-nix.git/blob - shell.nix
creds: move creds-* scripts to a NixOS module
[julm/julm-nix.git] / shell.nix
1 { pkgs, inputs, system, nixpkgsPath, ... }:
2 pkgs.mkShell {
3 name = "shell";
4 src = null;
5 #preferLocalBuild = true;
6 #allowSubstitutes = false;
7 buildInputs = [
8 (pkgs.nixos []).nixos-install
9 inputs.creds.packages.${system}.default
10 ];
11 #enableParallelBuilding = true;
12 NIX_PATH = pkgs.lib.concatStringsSep ":" [
13 "nixpkgs=${nixpkgsPath}"
14 "nixpkgs-overlays=${inputs.self}/nixpkgs/overlays.nix"
15 "home-manager=${inputs.home-manager}"
16 ];
17 shellHook = ''
18 echo >&2 "nix: running shellHook"
19 PATH="${inputs.home-manager.defaultPackage.${system}}/bin:$PATH"
20 PASSWORD_STORE_DIR=$PWD
21 nix-store --add-root nixpkgs.root --indirect --realise ${nixpkgsPath}
22 '';
23 }