1 { pkgs, hostName, ... }:
4 ../../nixos/profiles/hardware/E5500.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
10 # Avoids huge slow downs, especially with nix.
11 "zfs.zfs_arc_max=${toString (1024 * 1024 * 1024)}" # bytes
14 # Setting the machine-id avoids to reencrypt all credentials
15 # when reinstalling NixOS on a new drive.
16 # Manually generated with : uuidgen | tr -d -
17 environment.etc.machine-id.source = ./machine-id.clear;
19 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
20 # You should try to make this id unique among your hosts.
21 # Manually generated with : uuidgen | head -c8
22 networking.hostId = "e53001b7";
27 memtest86.enable = true;
31 devices = [ "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD5" ];
34 # Roughly 25MiB (initrd) + 9MiB (kernel) per configuration
35 configurationLimit = 6;
39 #enableCryptodisk = true;
42 boot.zfs.requestEncryptionCredentials = [ "${hostName}/root" ];
44 hardware.enableRedistributableFirmware = true;
46 fileSystems."/boot1" = {
47 device = "/dev/disk/by-partlabel/${hostName}_ssd1_boot";
60 device = "/dev/disk/by-partlabel/${hostName}_ssd1_swap";
63 cipher = "aes-xts-plain64";
64 source = "/dev/urandom";
69 boot.supportedFilesystems = [
75 device = "${hostName}/root";
77 options = [ "zfsutil" ];
79 fileSystems."/nix" = {
80 device = "${hostName}/root/nix";
87 fileSystems."/var" = {
88 device = "${hostName}/root/var";
96 services.pipewire.jack.enable = true;