10 ../../nixos/profiles/hardware/T14sAMDGen1.nix
11 ../../nixos/profiles/zfs.nix
12 #../../nixos/profiles/zramSwap.nix
15 # Setting the machine-id avoids to reencrypt all credentials
16 # when reinstalling NixOS on a new drive.
17 # Manually generated with : uuidgen | tr -d -
18 environment.etc.machine-id.source = ./machine-id.clear;
20 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
21 # You should try to make this id unique among your hosts.
22 # Manually generated with : uuidgen | head -c8
23 networking.hostId = "d70732b9";
31 # Deprecated in nixos-24.11
32 #boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
35 canTouchEfiVariables = true;
36 efiSysMountPoint = "/boot1";
41 # Roughly 25MiB (initrd) + 9MiB (kernel) per configuration
42 configurationLimit = 6;
43 memtest86.enable = true;
45 extraInstallCommands = ''
47 cp -r /efiboot/efi1 /efiboot/efi2
50 # FIXME: needs https://github.com/NixOS/nixpkgs/pull/246897
54 boot.zfs.requestEncryptionCredentials = [ "${hostName}/root" ];
56 #console.keyMap = lib.mkForce "de";
58 hardware.enableRedistributableFirmware = true;
60 fileSystems."/boot1" = {
61 device = "/dev/disk/by-partlabel/${hostName}_nvme1_boot";
74 device = "/dev/disk/by-partlabel/${hostName}_nvme1_swap";
77 cipher = "aes-xts-plain64";
78 source = "/dev/urandom";
83 boot.supportedFilesystems = [
89 device = "${hostName}/root";
91 options = [ "zfsutil" ];
93 fileSystems."/nix" = {
94 device = "${hostName}/root/nix";
101 fileSystems."/var" = {
102 device = "${hostName}/root/var";
110 services.pipewire.jack.enable = true;
113 # Suspending not work well on this old computer.
114 #lidEventCommands = "";