]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/hardware.nix
aubergine: enable serial profile
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
1 { pkgs, lib, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/serial.nix
7 ../../nixos/profiles/zfs.nix
8 ../../nixos/profiles/zramSwap.nix
9 ];
10
11 # Setting the machine-id avoids to reencrypt all credentials
12 # when reinstalling NixOS on a new drive.
13 # Manually generated with : uuidgen | tr -d -
14 environment.etc.machine-id.source = ./machine-id.clear;
15
16 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
17 # You should try to make this id unique among your hosts.
18 # Manually generated with : uuidgen | head -c8
19 networking.hostId = "408a404a";
20
21 /*
22 boot.loader.efi = {
23 canTouchEfiVariables = true;
24 efiSysMountPoint = "/boot/efi";
25 };
26 */
27 boot.loader.grub = {
28 enable = true;
29 devices = [
30 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
31 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
32 "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
33 ];
34 configurationLimit = 9;
35
36 #zfsSupport = true;
37 #efiSupport = true;
38 #enableCryptodisk = true;
39 };
40 boot.tmp.useTmpfs = true;
41 #boot.kernelPackages = pkgs.linuxKernel.packages.linux_4_14;
42 # linux-firmware-20230515
43 # linux-firmware-20221109
44 # linux-5.15.109 <-- working?
45 # linux-5.15.129
46
47 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
48 boot.extraModulePackages = [
49 #config.boot.kernelPackages.exfat-nofuse
50 ];
51
52 powerManagement.powertop.enable = true;
53 #services.fprintd.enable = true;
54
55 fileSystems."/" =
56 {
57 device = "${hostName}/root";
58 fsType = "zfs";
59 };
60 fileSystems."/boot" =
61 {
62 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
63 fsType = "ext4";
64 };
65 fileSystems."/boot/efi" =
66 {
67 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
68 fsType = "vfat";
69 };
70 fileSystems."/nix" =
71 {
72 device = "${hostName}/nix";
73 fsType = "zfs";
74 };
75 fileSystems."/var" =
76 {
77 device = "${hostName}/var";
78 fsType = "zfs";
79 };
80 fileSystems."/home" =
81 {
82 device = "${hostName}/home";
83 fsType = "zfs";
84 };
85 swapDevices =
86 [
87 {
88 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
89 randomEncryption = {
90 enable = true;
91 cipher = "aes-xts-plain64";
92 source = "/dev/urandom";
93 };
94 }
95 ];
96
97 hardware.pulseaudio.enable = lib.mkDefault true;
98 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
99
100 }