1 { pkgs, lib, hostName, ... }:
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/serial.nix
7 ../../nixos/profiles/zfs.nix
8 ../../nixos/profiles/zramSwap.nix
11 # Setting the machine-id avoids to reencrypt all credentials
12 # when reinstalling NixOS on a new drive.
13 # Manually generated with : uuidgen | tr -d -
14 environment.etc.machine-id.source = ./machine-id.clear;
16 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
17 # You should try to make this id unique among your hosts.
18 # Manually generated with : uuidgen | head -c8
19 networking.hostId = "408a404a";
23 canTouchEfiVariables = true;
24 efiSysMountPoint = "/boot/efi";
30 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
31 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
32 "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
34 configurationLimit = 9;
38 #enableCryptodisk = true;
40 boot.tmp.useTmpfs = true;
41 #boot.kernelPackages = pkgs.linuxKernel.packages.linux_4_14;
42 # linux-firmware-20230515
43 # linux-firmware-20221109
44 # linux-5.15.109 <-- working?
47 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
48 boot.extraModulePackages = [
49 #config.boot.kernelPackages.exfat-nofuse
52 powerManagement.powertop.enable = true;
53 #services.fprintd.enable = true;
57 device = "${hostName}/root";
62 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
65 fileSystems."/boot/efi" =
67 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
72 device = "${hostName}/nix";
77 device = "${hostName}/var";
82 device = "${hostName}/home";
88 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
91 cipher = "aes-xts-plain64";
92 source = "/dev/urandom";
97 hardware.pulseaudio.enable = lib.mkDefault true;
98 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;