]> Git — Sourcephile - julm/julm-nix.git/blob - networking/wireguard/wg-intra/hosts.nix
carotte: add to wg-intra
[julm/julm-nix.git] / networking / wireguard / wg-intra / hosts.nix
1 {
2 mermet = rec {
3 ipv4 = "192.168.42.1";
4 ips = ["${ipv4}/24"];
5 listenPort = 43642;
6 peersAnnouncing.enable = true;
7 peer = {
8 publicKey = "XbTEP2X71LBTjmdmySdiOpQJ+uIomcXvg1aiQGUtWBI=";
9 allowedIPs = [ "${ipv4}/32" ];
10 endpoint = "80.67.180.129:${toString listenPort}";
11 endpointsUpdater.enable = true;
12 };
13 };
14 losurdo = rec {
15 ipv4 = "192.168.42.2";
16 ips = ["${ipv4}/24"];
17 listenPort = 43643;
18 persistentKeepalive = 5;
19 peer = {
20 publicKey = "xsFFep3k8z0pXgUOz4aryOF8l/KPBSOd4WQA26BkXy0=";
21 allowedIPs = [ "${ipv4}/32" ];
22 };
23 };
24 oignon = rec {
25 ipv4 = "192.168.42.3";
26 ips = ["${ipv4}/24"];
27 listenPort = 43644;
28 #persistentKeepalive = 10;
29 peer = {
30 publicKey = "tE4fzqDrr7BgfOo9tWgGnpu3v0JRDEUZbJnm9e2F/GA=";
31 allowedIPs = [ "${ipv4}/32" ];
32 persistentKeepalive = 15;
33 #dynamicEndpointRefreshSeconds = 60;
34 };
35 };
36 patate = rec {
37 ipv4 = "192.168.42.4";
38 ips = ["${ipv4}/24"];
39 listenPort = 43645;
40 #persistentKeepalive = 10;
41 peer = {
42 publicKey = "gaEz7nvJTk4h3DGOpeZXSWmYDDrc5xQkuJ28sGrksx4=";
43 allowedIPs = [ "${ipv4}/32" ];
44 persistentKeepalive = 15;
45 #dynamicEndpointRefreshSeconds = 60;
46 };
47 };
48 carotte = rec {
49 ipv4 = "192.168.42.5";
50 ips = ["${ipv4}/24"];
51 #persistentKeepalive = 10;
52 listenPort = 43646;
53 peer = {
54 publicKey = "33yNfMAIRMjwqwYszPzVGqclkAGgW6RGsnBnSzRKXm0=";
55 allowedIPs = [ "${ipv4}/32" ];
56 persistentKeepalive = 15;
57 #dynamicEndpointRefreshSeconds = 60;
58 };
59 };
60 }