5 enable = mkDefault true;
6 enableCompletion = mkDefault true;
8 afk = "xset s activate dpms force off";
9 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
12 dust = "dust --bars-on-right --full-paths";
13 emacs = "emacsclient --create-frame";
14 grep = "grep --color";
15 j = "sudo journalctl -u";
16 jb = "sudo journalctl -b";
17 ju = "journalctl --user -u";
20 ls = "ls --color=tty";
21 lst = "ls --sort=time --reverse -1";
22 md-toc = "grep '^#\\+' --color";
23 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
24 mem-top = "smem --sort rss --autosize";
26 n = "sudo networkctl";
27 nf = "sudo nft list ruleset | less";
28 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
29 nixos-clean = "sudo nix-collect-garbage -d";
30 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
31 nixos-rollback = "sudo nixos-rebuild switch --rollback";
32 nt = "sudo networkctl status";
33 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
35 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
36 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
37 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
39 sr = "sudo systemctl restart";
40 ssh-unknown = "ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null";
41 st = "sudo systemctl status";
46 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
47 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
48 u = "systemctl --user";
49 ur = "systemctl --user restart";
50 ut = "systemctl --user status";
51 w = "watch --color --differences";
52 w1 = "watch --color --differences --interval 1";
53 w10 = "watch --color --differences --interval 10";
54 w5 = "watch --color --differences --interval 5";
55 watch = "watch --color --differences";
57 ze = "sudo zpool export";
58 zfs-umount = "zfs-unmount";
59 zi = "sudo zpool import";
61 zlb = "zfs list -t bookmarks";
62 zls = "zfs list -t snap";
66 zs5 = "w5 zpool status";
69 historyControl = [ "erasedups" "ignorespace" ];
76 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
77 # More throughput than chacha20-poly1305@openssh.com
78 # on hardware with AES acceleration.
79 RSYNC_RSH = "ssh -c aes128-gcm@openssh.com,chacha20-poly1305@openssh.com";
83 . ${pkgs.complete-alias}/bin/complete_alias
84 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
90 # Disable ctrl-s/ctrl-q flow control
95 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio-only.mkv
100 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
104 find "$@" -depth -type f -print0 | sort -n -z |
105 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
106 test -e "''${0%.*}".opus ||
107 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
112 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
113 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
122 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
125 device=''${1:-/dev/sda}
126 sudo smartctl -A $device |
128 $0 ~ /Power_On_Hours/ {
130 printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25
132 $0 ~ /Total_LBAs_Written/ {
138 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
139 printf "mean writes per hour / %.2f", mb/poh
141 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
142 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
143 $0 ~ /Percentage Used:/ { printf "Percentage_Used / %d\n", int($3) }
146 sed -e "s\$^\$$device @ \$" |
149 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
150 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
151 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
155 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
156 while IFS=: read -r file x size x
162 if test "$pid" = "$lastpid"
163 then swap=$(( swap + size ))
165 if test "$swap" -gt 0
166 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
168 if test "$pid" = self
179 # Recursively mount not-mounted dataset,
180 # loading their keys if needed.
184 for d in $(zfs list -rH -o name "$@"); do
185 mountpoint /mnt/"$d" 2>/dev/null ||
186 sudo zfs mount -l "$d"
190 # Recursively unmount dataset,
191 # unloading their keys.
192 zfs-unmount () { sudo zfs unmount -u "$@"; }
194 # Create bookmarks for all the snapshots of the given datasets.
195 # Bookmarks are only useful on source datasets
196 # But syncoid --create-bookmark only creates
197 # a bookmark for the latest snapshot,
198 # possibly leaving the *_daily or *_monthly snapshots without a bookmark.
199 zfs-fix-bookmarks () {
204 for s in $(zfs list -Hrpt snapshot -o name "$d"); do
205 zfs bookmark "$s" "''${s//@/#}"
210 # Restore the inheritance of encryptionroot,
211 # usually broken by zfs send --raw.
212 # Note that it needs to decrypt the datasets.
213 zfs-fix-encryptionroot () {
216 for d in $(zfs list -rHo name "$1" | tail -n +2); do
218 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
219 zfs change-key -li "$d"
223 # Recursively remove all the snapshots of given datasets
224 zfs-destroy-snapshots () {
227 zfs list -t snapshot -rHo name "$d" |
228 xargs --no-run-if-empty -L1 zfs destroy
235 #programs.broot.enableBashIntegration = true;
236 programs.readline = {
237 enable = mkDefault true;
238 includeSystemConfig = true;
241 "\\e[A" = "history-search-backward";
242 "\\e[B" = "history-search-forward";
243 "\\eOA" = "history-search-backward";
244 "\\eOB" = "history-search-forward";
246 # Ctrl-Left/Ctrl-Right
247 "\\e[1;5C" = "forward-word";
248 "\\e[1;5D" = "backward-word";
249 "\\e[5C" = "forward-word";
250 "\\e[5D" = "backward-word";
251 "\\e\\e[C" = "forward-word";
252 "\\e\\e[D" = "backward-word";
255 "\\e[1~" = "beginning-of-line";
256 "\\e[4~" = "end-of-line";
259 "\\e[3~" = "delete-char";
260 "\\e[2~" = "quoted-insert";
262 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
263 "\\eOF" = "end-of-line";
264 "\\eOH" = "beginning-of-line";
266 # For freebsd console
267 "\\e[F" = "end-of-line";
268 "\\e[H" = "beginning-of-line";
271 "\\e[7~" = "beginning-of-line";
272 "\\e[8~" = "end-of-line";
273 "\\eOc" = "forward-word";
274 "\\eOd" = "backward-word";
279 input-meta = mkDefault true;
280 output-meta = mkDefault true;
281 colored-completion-prefix = mkDefault true;
282 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
283 echo-control-characters = mkDefault true;
284 mark-symlinked-directories = mkDefault true;
285 menu-complete-display-prefix = mkDefault true;
286 show-all-if-ambiguous = mkDefault true;
287 show-all-if-unmodified = mkDefault true;
288 visible-stats = mkDefault false; # Append char to indicate type
289 enable-bracketed-paste = mkDefault true;