]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/graphical.nix
aubergine: pipewire: enable
[julm/julm-nix.git] / home-manager / profiles / graphical.nix
1 { pkgs, lib, config, nixosConfig, ... }:
2 {
3 imports = [
4 ./redshift.nix
5 ];
6 home.packages = [
7 pkgs.arandr
8 pkgs.glib.bin
9 pkgs.glxinfo
10 pkgs.gnome.dconf-editor
11 pkgs.hicolor-icon-theme
12 pkgs.pavucontrol
13 pkgs.qpwgraph
14 pkgs.x2goclient
15 pkgs.xclip
16 pkgs.xorg.xkill
17 ];
18 #services.gnome.at-spi2-core.enable = true;
19 home.sessionVariables = lib.mkIf (!nixosConfig.services.gnome.at-spi2-core.enable) {
20 NO_AT_BRIDGE = "1";
21 };
22 # keycode <num> = <x> <Shift+x> _ _ <AltGr+x> <AltGr+Shift+x> _ _"
23 home.file.".Xmodmap".text = ''
24 ! — (tiret insécable) with AltGr+Shift+-
25 keycode 15 = minus 6 bar fiveeighths bar U2011
26 ! — (tiret cadratin) with AltGr+Shift+_
27 keycode 17 = underscore 8 bar fiveeighths backslash emdash
28 ! œ with AltGr+o
29 ! Œ with AltGr+Shift+o
30 keycode 32 = o O o O oe OE
31 ! … (ellipsis) with AltGr+;
32 keycode 59 = semicolon period comma less ellipsis multiply ccedilla Ccedilla
33 !   (nbsp) with AltGr+space and   (narrow nbsp) with AltGr+Shift+space
34 keycode 65 = space space NoSymbol NoSymbol nobreakspace U202F
35 '';
36 systemd.user.services.setxkbmap.Service.ExecStartPost =
37 "${pkgs.xorg.xmodmap}/bin/xmodmap ${config.home.homeDirectory}/.Xmodmap";
38 programs.bash.shellAliases = {
39 gtk-light = "dconf write /org/gnome/desktop/interface/color-scheme '\"prefer-light\"'";
40 gtk-dark = "dconf write /org/gnome/desktop/interface/color-scheme '\"prefer-dark\"'";
41 };
42 dconf.settings = {
43 "org/gnome/desktop/interface" = {
44 color-scheme = lib.mkDefault "prefer-dark";
45 };
46 };
47 gtk = {
48 enable = lib.mkDefault true;
49 theme.name = "Adwaita";
50 theme.package = pkgs.gnome.gnome-themes-extra;
51 iconTheme.package = pkgs.gnome.adwaita-icon-theme;
52 iconTheme.name = "Adwaita";
53 gtk2.configLocation = "${config.xdg.configHome}/gtk-2.0/gtkrc";
54 gtk3 = {
55 bookmarks = lib.mkDefault [
56 ];
57 };
58 };
59 }