]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/htop.nix
aubergine: pipewire: enable
[julm/julm-nix.git] / home-manager / profiles / htop.nix
1 { pkgs, lib, ... }:
2 {
3 # This must appear before "column_meters_*" options
4 xdg.configFile."htop/htoprc".text = lib.mkBefore ''
5 header_layout=two_50_50
6 '';
7 # Htop overrides its config on each quit,
8 # forcing the overwrite avoid subsequent invocations of home-manager to fail.
9 xdg.configFile."htop/htoprc".force = true;
10 programs.htop = {
11 enable = lib.mkDefault true;
12 settings = {
13 account_guest_in_cpu_meter = false;
14 all_branches_collapsed = false;
15 color_scheme = false;
16 column_meter_modes_0 = "3 1 1 1";
17 column_meter_modes_1 = "2 2 2 3 1 3 1 1 1 1";
18 column_meters_0 = "AllCPUs Memory Swap Zram";
19 column_meters_1 = "Hostname Systemd SystemdUser LoadAverage Uptime DiskIO DiskIO NetworkIO NetworkIO ZFSARC ZFSCARC PressureStallIOFull";
20 cpu_count_from_one = false;
21 degree_fahrenheit = false;
22 delay = 15;
23 detailed_cpu_time = true;
24 enable_mouse = true;
25 find_comm_in_cmdline = true;
26 header_margin = true;
27 hide_function_bar = false;
28 hide_kernel_threads = false;
29 hide_threads = true;
30 hide_userland_threads = true;
31 highlight_base_name = true;
32 highlight_changes = true;
33 highlight_changes_delay_secs = 5;
34 highlight_deleted_exe = true;
35 highlight_megabytes = true;
36 highlight_threads = true;
37 screen_tabs = true;
38 shadow_other_users = false;
39 show_cpu_frequency = true;
40 show_cpu_temperature = false;
41 show_cpu_usage = true;
42 show_merged_command = false;
43 show_program_path = false;
44 show_thread_names = false;
45 sort_direction = 0;
46 sort_key = 46; # PERCENT_CPU
47 strip_exe_from_cmdline = true;
48 tree_sort_direction = 0;
49 tree_sort_key = 46; # PERCENT_CPU
50 tree_view = true;
51 tree_view_always_by_pid = false;
52 update_process_names = false;
53 /*
54 "screen:Main" = ''
55 PID USER PRIORITY NICE M_VIRT M_RESIDENT M_SHARE STATE PERCENT_CPU PERCENT_MEM TIME Command
56 .sort_key=PERCENT_CPU
57 .tree_sort_key=PERCENT_CPU
58 .tree_view=1
59 .tree_view_always_by_pid=0
60 .sort_direction=0
61 .tree_sort_direction=0
62 .all_branches_collapsed=0
63 '';
64 "screen:I/O" = ''
65 PID USER IO_PRIORITY IO_RATE IO_READ_RATE IO_WRITE_RATE
66 .sort_key=IO_RATE
67 .tree_sort_key=PID
68 .tree_view=0
69 .tree_view_always_by_pid=0
70 .sort_direction=-1
71 .tree_sort_direction=1
72 .all_branches_collapsed=0
73 '';
74 */
75 };
76 };
77 }