1 { config, pkgs, lib, inputs, hostName, ... }:
4 ../nixos/profiles/graphical.nix
5 ../nixos/profiles/lang-fr.nix
6 ../nixos/profiles/laptop.nix
7 ../nixos/profiles/printing.nix
13 # Lower kernel's security for better performances
14 security.kernel.mitigations = "off";
16 home-manager.users.mo = {
17 imports = [ ../homes/mo.nix ];
20 openssh.authorizedKeys.keys = map lib.readFile [
21 ../users/julm/ssh/oignon.pub
22 ../users/julm/ssh/losurdo.pub
28 # Put the hashedPassword in /nix/store,
29 # though /etc/shadow is not world readable...
30 # printf %s $(mkpasswd -m yescrypt)
31 hashedPassword = lib.readFile courge/users/mo/login/hashedPassword.clear;
37 #"plugdev" # For rtl-sdr
43 #config.services.davfs2.davGroup
46 # If created, zfs-mount.service would require:
47 # zfs set overlay=yes ${hostName}/home
49 openssh.authorizedKeys.keys = map lib.readFile [
50 ../users/julm/ssh/oignon.pub
51 ../users/julm/ssh/losurdo.pub
55 environment.systemPackages = [
56 #pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
59 boot.extraModulePackages = [
62 #programs.fuse.userAllowOther = true;
73 services.displayManager = {
74 defaultSession = "gnome";
76 user = config.users.users.mo.name;
80 # This value determines the NixOS release with which your system is to be
81 # compatible, in order to avoid breaking some software such as database
82 # servers. You should change this only after NixOS release notes say you should.
83 system.stateVersion = "23.05"; # Did you read the comment?