5 enable = mkDefault true;
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 ju = "sudo journalctl --user -u";
21 ls = "ls --color=tty";
22 md-toc = "grep '^#\\+' --color";
23 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
24 mem-top = "smem --sort rss --autosize";
26 nf = "sudo nft list ruleset | less";
27 nixos-clean = "sudo nix-collect-garbage -d";
28 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
29 nixos-rollback = "sudo nixos-rebuild switch --rollback";
30 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
32 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
33 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
34 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
36 st = "sudo systemctl status";
37 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
38 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
39 u = "systemctl --user";
40 ut = "systemctl --user status";
41 w1 = "watch --color --differences --interval 1";
42 w5 = "watch --color --differences --interval 5";
43 w10 = "watch --color --differences --interval 10";
44 w = "watch --color --differences";
45 watch = "watch --color --differences";
46 zfs-umount = "zfs-unmount";
49 HISTCONTROL = "erasedups:ignorespace";
51 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
55 . ${pkgs.complete-alias}/bin/complete_alias
56 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
62 # Disable ctrl-s/ctrl-q flow control
67 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
68 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
77 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
80 find "$@" -depth -type f -print0 | sort -n -z |
81 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
82 test -e "''${0%.*}".opus ||
83 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
87 device=''${1:-/dev/sda}
88 sudo smartctl -A $device |
90 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
91 $0 ~ /Total_LBAs_Written/ {
97 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
98 printf "mean writes per hour: / %.2f", mb/poh
100 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
101 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
104 sed -e "s\$^\$$device @ \$" |
107 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
108 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
109 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
113 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
114 while IFS=: read -r file x size x
120 if test "$pid" = "$lastpid"
121 then swap=$(( swap + size ))
123 if test "$swap" -gt 0
124 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
126 if test "$pid" = self
136 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
137 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
139 # Recursively mount not-mounted dataset,
140 # loading their keys if needed.
142 for d in $(zfs list -rH -o name "$@"); do
143 mountpoint /mnt/"$d" 2>/dev/null ||
144 sudo zfs mount -l "$d"
147 # Recursively unmount dataset,
148 # unloading their keys.
149 zfs-unmount () { sudo zfs unmount -u "$@"; }
151 # Restore the inheritance of encryptionroot,
152 # usually broken by zfs send --raw.
153 # Note that it needs to decrypt the datasets.
154 zfs-fix-encryptionroot () {
156 for i in $(zfs list -rHo name "$1" | tail -n +2); do
158 test "$(zfs get -Ho value encryptionroot $i)" = "$1" ||
159 zfs change-key -li "$i"
166 programs.direnv.enableBashIntegration = true;
167 #programs.broot.enableBashIntegration = true;
168 programs.readline = {
169 enable = mkDefault true;
170 includeSystemConfig = true;
173 "\\e[A" = "history-search-backward";
174 "\\e[B" = "history-search-forward";
176 # Ctrl-Left/Ctrl-Right
177 "\\e[1;5C" = "forward-word";
178 "\\e[1;5D" = "backward-word";
179 "\\e[5C" = "forward-word";
180 "\\e[5D" = "backward-word";
181 "\\e\\e[C" = "forward-word";
182 "\\e\\e[D" = "backward-word";
185 "\\e[1~" = "beginning-of-line";
186 "\\e[4~" = "end-of-line";
189 "\\e[3~" = "delete-char";
190 "\\e[2~" = "quoted-insert";
192 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
193 "\\eOF" = "end-of-line";
194 "\\eOH" = "beginning-of-line";
196 # For freebsd console
197 "\\e[F" = "end-of-line";
198 "\\e[H" = "beginning-of-line";
201 "\\e[7~" = "beginning-of-line";
202 "\\e[8~" = "end-of-line";
203 "\\eOc" = "forward-word";
204 "\\eOd" = "backward-word";
209 input-meta = mkDefault true;
210 output-meta = mkDefault true;
211 colored-completion-prefix = mkDefault true;
212 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
213 echo-control-characters = mkDefault true;
214 mark-symlinked-directories = mkDefault true;
215 menu-complete-display-prefix = mkDefault true;
216 show-all-if-ambiguous = mkDefault true;
217 show-all-if-unmodified = mkDefault true;
218 visible-stats = mkDefault false; # Append char to indicate type
219 enable-bracketed-paste = mkDefault true;