]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: add function opusenc-voice
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 shellAliases = {
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
8 c = "bat";
9 cl = "clear";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
13 g = "git";
14 gg = "git grep";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 l = "ls -alh";
19 ll = "ls -al";
20 ls = "ls --color=tty";
21 md-toc = "grep '^#\\+' --color";
22 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
23 mem-top = "smem --sort rss --autosize";
24 mpl = "mplayer";
25 nf = "sudo nft list ruleset | less";
26 nixos-clean = "sudo nix-collect-garbage -d";
27 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
28 nixos-rollback = "sudo nixos-rebuild switch --rollback";
29 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
30 r = "reset";
31 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
32 s = "sudo systemctl";
33 st = "sudo systemctl status";
34 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
35 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
36 u = "systemctl --user";
37 ut = "systemctl --user status";
38 w1 = "watch --color --differences --interval 1";
39 w5 = "watch --color --differences --interval 5";
40 w10 = "watch --color --differences --interval 10";
41 w = "watch --color --differences";
42 watch = "watch --color --differences";
43 zfs-umount = "zfs-unmount";
44 };
45 sessionVariables = {
46 HISTCONTROL = "erasedups:ignorespace";
47 HISTSIZE = "42000";
48 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
49 };
50 initExtra = ''
51 # Alias completion
52 . ${pkgs.complete-alias}/bin/complete_alias
53 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
54
55 shopt -s globstar
56 shopt -s histappend
57 shopt -s histreedit
58 shopt -s histverify
59 # Disable ctrl-s/ctrl-q flow control
60 stty -ixon
61
62 ibm-fan () {
63 if [ $# -gt 0 ]
64 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
65 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
66 fi
67 acpi -t
68 }
69 mkcd () {
70 mkdir -p "$1" &&
71 cd "$1"
72 }
73 mkpass () {
74 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
75 }
76 opusenc-voice () {
77 find "$@" -depth -type f -print0 | sort -n -z |
78 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
79 test -e "''${0%.*}".opus ||
80 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
81 ' {} \;
82 }
83 smartctl-tbw () {
84 device=''${1:-/dev/sda}
85 sudo smartctl -A $device |
86 { awk '
87 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
88 $0 ~ /Total_LBAs_Written/ {
89 lbas = $10;
90 bytes = $10 * 512;
91 mb = bytes / 1024^2;
92 gb = bytes / 1024^3;
93 tb = bytes / 1024^4;
94 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
95 printf "mean writes per hour: / %.2f", mb/poh
96 }
97 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
98 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
99 '; echo; } |
100 sed -e 's:/:@:' |
101 sed -e "s\$^\$$device @ \$" |
102 column -ts@
103 }
104 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
105 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
106 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
107 swaplist () {
108 lastpid=
109 swap=0
110 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
111 while IFS=: read -r file x size x
112 do
113 pid=''${file#/proc/}
114 pid=''${pid%/smaps}
115 size=''${size% kB}
116 size=''${size##* }
117 if test "$pid" = "$lastpid"
118 then swap=$(( swap + size ))
119 else
120 if test "$swap" -gt 0
121 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
122 fi
123 if test "$pid" = self
124 then break
125 else
126 lastpid=$pid
127 swap=$size
128 fi
129 fi
130 done |
131 sort -nk1,1
132 }
133 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
134 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
135
136 # Recursively mount not-mounted dataset,
137 # loading their keys if needed.
138 zfs-mount () {
139 for d in $(zfs list -rH -o name "$@"); do
140 mountpoint /mnt/"$d" 2>/dev/null ||
141 sudo zfs mount -l "$d"
142 done
143 }
144 # Recursively unmount dataset,
145 # unloading their keys.
146 zfs-unmount () { sudo zfs unmount -u "$@"; }
147
148 # Restore the inheritance of encryptionroot,
149 # usually broken by zfs send --raw.
150 # Note that it needs to decrypt the datasets.
151 zfs-fix-encryptionroot () {
152 zfs load-key "$1"
153 for i in $(zfs list -rHo name "$1" | tail -n +2); do
154 echo >&2 "$i"
155 test "$(zfs get -Ho value encryptionroot $i)" = "$1" ||
156 zfs change-key -li "$i"
157 done
158 }
159 '';
160 profileExtra = ''
161 '';
162 };
163 programs.direnv.enableBashIntegration = true;
164 #programs.broot.enableBashIntegration = true;
165 programs.readline = {
166 enable = mkDefault true;
167 includeSystemConfig = true;
168 bindings = {
169 # Up/Down
170 "\\e[A" = "history-search-backward";
171 "\\e[B" = "history-search-forward";
172
173 # Ctrl-Left/Ctrl-Right
174 "\\e[1;5C" = "forward-word";
175 "\\e[1;5D" = "backward-word";
176 "\\e[5C" = "forward-word";
177 "\\e[5D" = "backward-word";
178 "\\e\\e[C" = "forward-word";
179 "\\e\\e[D" = "backward-word";
180
181 # Home/End
182 "\\e[1~" = "beginning-of-line";
183 "\\e[4~" = "end-of-line";
184
185 # Delete/Insert
186 "\\e[3~" = "delete-char";
187 "\\e[2~" = "quoted-insert";
188
189 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
190 "\\eOF" = "end-of-line";
191 "\\eOH" = "beginning-of-line";
192
193 # For freebsd console
194 "\\e[F" = "end-of-line";
195 "\\e[H" = "beginning-of-line";
196
197 # $if term=rxvt
198 "\\e[7~" = "beginning-of-line";
199 "\\e[8~" = "end-of-line";
200 "\\eOc" = "forward-word";
201 "\\eOd" = "backward-word";
202 # $endif
203 };
204 variables = {
205 # Be 8 bit clean.
206 input-meta = mkDefault true;
207 output-meta = mkDefault true;
208 colored-completion-prefix = mkDefault true;
209 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
210 echo-control-characters = mkDefault true;
211 mark-symlinked-directories = mkDefault true;
212 menu-complete-display-prefix = mkDefault true;
213 show-all-if-ambiguous = mkDefault true;
214 show-all-if-unmodified = mkDefault true;
215 visible-stats = mkDefault false; # Append char to indicate type
216 enable-bracketed-paste = mkDefault true;
217 };
218 };
219 }