17 pkgs.hicolor-icon-theme
24 #services.gnome.at-spi2-core.enable = true;
25 home.sessionVariables = lib.mkIf (!nixosConfig.services.gnome.at-spi2-core.enable) {
28 # keycode <num> = <x> <Shift+x> _ _ <AltGr+x> <AltGr+Shift+x> _ _"
29 home.file.".Xmodmap".text = ''
30 ! — (tiret insécable) with AltGr+Shift+-
31 keycode 15 = minus 6 bar fiveeighths bar U2011
32 ! — (tiret cadratin) with AltGr+Shift+_
33 keycode 17 = underscore 8 bar fiveeighths backslash emdash
35 ! Œ with AltGr+Shift+o
36 keycode 32 = o O o O oe OE
37 ! … (ellipsis) with AltGr+;
38 keycode 59 = semicolon period comma less ellipsis multiply ccedilla Ccedilla
39 ! (nbsp) with AltGr+space and (narrow nbsp) with AltGr+Shift+space
40 keycode 65 = space space NoSymbol NoSymbol nobreakspace U202F
42 ! Use Caps Lock button for compose key
43 keysym Caps_Lock = Multi_key Caps_Lock
44 ! Remove shift lock functionality
47 systemd.user.services.setxkbmap.Service.ExecStartPost =
48 "${pkgs.xorg.xmodmap}/bin/xmodmap ${config.home.homeDirectory}/.Xmodmap";
54 dconf write /org/gnome/desktop/interface/color-scheme "'prefer-dark'"
55 echo 'Net/ThemeName "Adwaita-dark"' > ~/.xsettingsd
56 systemctl --user kill -s HUP xsettingsd.service
59 dconf write /org/gnome/desktop/interface/color-scheme "'prefer-light'"
60 echo 'Net/ThemeName "Adwaita"' > ~/.xsettingsd
61 systemctl --user kill -s HUP xsettingsd.service
63 *) echo "Usage: dark-mode <dark|light>";;
68 # Required for gtk-theme to work.
69 services.xsettingsd.enable = true;
71 "org/gnome/desktop/interface" = {
72 color-scheme = lib.mkDefault "prefer-dark";
76 enable = lib.mkDefault true;
77 theme.name = "Adwaita";
78 theme.package = pkgs.gnome-themes-extra;
79 iconTheme.package = pkgs.adwaita-icon-theme;
80 iconTheme.name = "Adwaita";
81 gtk2.configLocation = "${config.xdg.configHome}/gtk-2.0/gtkrc";
83 bookmarks = lib.mkDefault [